Bitsum Community Forum

General Category => General => Topic started by: empleat on October 16, 2020, 08:41:48 AM

Title: Cpu affinity doesn't change by the rules
Post by: empleat on October 16, 2020, 08:41:48 AM
Well this is strange. In process lasso, under rules affinity is set to 0-5, but cpu affinity is 1. Even if i change it again, it keeps reverting to 1. Even if i select always. Process is steam and steamwebhelper. Than my game has also 1 core and i can't change it, unless i change it for steam. But it keeps reverting to 1. I didn't change any pro balance setting. And tried different profile, didn't help. No idea why it does that...

Thanks for help.

EDIT: restarted steam and process lasso, now it is fine, never mind.
Title: Re: Cpu affinity doesn't change by the rules
Post by: Jeremy Collake on October 16, 2020, 09:10:56 AM
My first guess might be you are seeing a CPU affinity inheritance from steam to its child process(es). If you've set rules for Steam, be aware you'll need to set other rules for your game processes to prevent Steam rules from propagating to the children. Let us know if it happens again and post your INI file contents here.
Title: Re: Cpu affinity doesn't change by the rules
Post by: empleat on October 16, 2020, 11:08:45 AM
My first guess might be you are seeing a CPU affinity inheritance from steam to its child process(es). If you've set rules for Steam, be aware you'll need to set other rules for your game processes to prevent Steam rules from propagating to the children. Let us know if it happens again and post your INI file contents here.
I didn't set rules. It was putting it to 1 for some reason. Doesn't matter anymore.
Title: Re: Cpu affinity doesn't change by the rules
Post by: Jeremy Collake on October 20, 2020, 12:16:21 PM
Well, *something* was putting them to 1 ;).

Let us know if it reoccurs!