Bitsum Community Forum

General Category => Process Lasso => Bug Reports => Topic started by: Keefaetana on January 21, 2021, 12:33:59 PM

Title: Turning logging off doesn't work
Post by: Keefaetana on January 21, 2021, 12:33:59 PM
I've turned logging off in Process Lasso by un-checking "Logging enabled", but Lasso still keeps on adding actions to the log. I am currently using the version 9.9.4.79 beta. I haven't noticed the issue before, but it may have already existed in previous versions.
Title: Re: Turning logging off doesn't work
Post by: edkiefer on January 21, 2021, 06:04:35 PM
Thanks for the report, it seems to be working fine on my end (9.9.4.81 beta) but will test some other options.

PL is undergoing some big changes in logging, but we are currently testing now.
Title: Re: Turning logging off doesn't work
Post by: Keefaetana on January 22, 2021, 02:13:52 AM
Thank you for replying.

I additionally tried un-checking all the individual "Log process launches", "Log process terminations", and everything below it. The issue still persists.

Next up, I exported my settings and reset my configuration via Options. Let's see if that fixes the issue.

EDIT: Nope, doesn't fix the issue fully. The only settings I changed after resetting the whole configuration was to disable logging by un-checking "Logging enabled", and to enable "Lower I/O priority during restraint", and very soon "I/O priority class lowered" shows up in the Actions log. Also, I updated to 9.9.4.81 beta before the latest test.
Title: Re: Turning logging off doesn't work
Post by: edkiefer on January 22, 2021, 07:47:03 AM
Can you try something, note any change then open the config file in (prolasso.ini) by Menu, File> "manual edit the config file".
See if your changes match what the file says under [Logging] halfway down the file.


Edit, Thank you for the detailed report, no need to test my above comment, I have repro your test. It is the option "Lower I/O priority during restraint" that is causing it.
Title: Re: Turning logging off doesn't work
Post by: Jeremy Collake on January 22, 2021, 11:01:47 AM
This will be fixed in 9.9.4.83. It did exist in all prior versions. The option to lower I/O priority during ProBalance restraints is seldom used, so this was missed until now. Thanks for reporting it!