Power Profile Problems

Started by flyg, July 03, 2020, 10:47:10 AM

Previous topic - Next topic



My computer always starts up now in power save mode - nothing in startup telling it to do this. I have made sure to shutdown as balanced but it comes back as powersave.

I also have a specific process (in thsi case wow classic) set to high performance and performance mode but its totally ignored and stays as powersave.

I've attached some screenshots that might help. Everything ran perfect until i did a clean install of Windows 10 2004 so in theory the computer is very clean - not even installed 3rd party AV etc yet.

Have i set something silly?


Also attached high designated process list and a picture of me starting wow, process lasso changing its affinity etc but ignoring the power setting and leaving PC on powersave.


You have idlesaver enabled so after 15sec it will switch to power saver plan.
Are you saying when at the desktop if you move the mouse it doesn't return to default power plan?

On wowclassic not going into performance mode.
Try this, remove the entry listed in the menu option and start the game then right-click on the wowclassic process and enable performance mode in the menu option there.
See if that works.

I have tested idlesaver and performance mode in 2004 and it all seems to work here fine.

In the menu options make sure these are set on. Options>power>performance mode> "change power plan when engaged", "disable idlesaver when game is running"
With the first option above you can also change what power plan is used in performance mode with "select power plan to use", I recommend BHP one but check it anyway.
Bitsum QA Engineer

Jeremy Collake

I don't immediately have an explanation for what you are seeing, but will dig into it.

Please copy/paste or attach your INI configuration file here. You can get to it by 'File / Manually edit configuration file'.

Your log files may also be helpful. You can get to them by right-clicking on a log row and selecting 'Jump to log file on disk'.
Software Engineer. Bitsum LLC.


Thanks - ive attached the ini, the log file and a big two monitor picture showing process lasso on one monitor changing affinities and wow loading with taskbar up showing power remaining on powersaver.

also tried the suggestion of removing from high process list and adding them again but didn't make a difference.

ini file - https://www.mediafire.com/file/lvh4oir9ywrc6b3/prolasso.ini/file
log file - https://www.mediafire.com/file/pnfgpoui0i8vtim/prolasso.log/file
pic - https://ibb.co/qkfTZps

ps-  mediafire as couldn't attach banned file types.

Jeremy Collake

I found that the Application Power plan rule for wowclassic.exe is being ignored due to its 'Induce Performance Mode' classification. This is because Performance Mode is also set to change the power plan, and thus the rules would have conflicted, resulting in potentially unexpected behavior.

Secondarily, Performance Mode was not being engaged because it was already on, by way of manual induction via the Process Lasso menu. I assume you clicked it on at some point? It appears so.

Manually entering Performance Mode and/or switching power plans while processes with power rules are running can result in unintended behavior.

Somehow (unclear how) you were in 'Power Saver' while in Performance Mode, so it may not have been obvious, with only the 'Performance Mode' text on the graph indicating this state.

The newly issued beta build v9.9.0.19 allows Application Power Profiles to be combined with Performance Mode on the same process. This should resolve the problem, but this adjustment is considered experimental at this time, due to the inherent rule conflict.

* Uncheck 'Induce Performance Mode' on wowclassic.exe
* OR exit all games/apps and turn off Performance Mode if engaged (then don't engage manually again)
* OR try experimental v9.9.0.19 beta

Let me know how that goes!
Software Engineer. Bitsum LLC.


I tried the new beta and its working fine now- thanks :D