Author Topic: error message  (Read 8157 times)

Offline project-nz

  • New
  • *
  • Posts: 1
error message
« on: May 04, 2009, 10:38:54 PM »
hi i have ubuntu 9.04 with all
the right pre requisites

using dd-wrt v24 pre sp2

and im still getting the same error message "firmware image format not compatible".

Firmware Mod Kit (extract) v0.62 beta, (c)2008 Jeremy Collake
 http://www.bitsum.com
 Checking for updates ...
  You have the latest version of this kit.
 LINUX system detected. Compatibility ok.
 Testing file system of finish ...
 Building tools ...
 ERROR - Build did not succeed. Check log file, you are probably
         missing one or more necessary pre-requisites. See docs for
         a list of pre-requsites.
 CONTINUING anyway, attempting to use pre-built binaries (x32 linux)
 Preparing working directory ...
 Removing any previous files ...
 Creating directories ...
 Extracting firmware
 Attempting raw linux style firmware package (i.e. TEW-632BRP) ...
 Extracting dir300-firmware.bin to finish ...
 Error: filesystem not extracted properly.
  firmware image format not compatible?

i have the link if someone can possible download the bin file and see if they can extract it thanks?

link is: [removed by editor]
« Last Edit: May 04, 2009, 11:52:07 PM by jeremy.collake »



Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5243
  • Gender: Male
  • The Lasso
    • Bitsum
Re: error message
« Reply #1 on: May 04, 2009, 11:50:18 PM »
The FMK does not support DIR300 type images of DD-WRT, sorry.
Software Engineer. Bitsum LLC.

Offline Lucian_rider

  • New
  • *
  • Posts: 3
Re: error message
« Reply #2 on: May 09, 2009, 07:07:17 PM »
I finally managed to get the firmware mod kit to work after installing the zlibc and zlib1 packages in synaptic package manager. I found this out myself after not getting any help figuring out which packages were necessary other than the ones in the system requirements section of the instructions...

It was very frustrating as my Linux experience is very limited.

If the tools don't get built then it is not going to work and as you are getting that error I would suggest that you have to get that working first.

Good luck.