Process Lasso wouldn't start - fixed all by myself...

Started by Arbor, July 13, 2013, 01:38:19 PM

Previous topic - Next topic


I have recently been having problems with PL not starting with Windows (Win 7 32-bit).  If I started it manually, it sometimes would just stop.  I finally took the time to investigate and of course uninstalled, reinstalled the latest version (6.6.060) etc.

Nothing helped, until on the nth trip through the Startup Config screens I noticed that on Multi-User Options I had told PL to "Use a custom file system location".  I don't know why I did this, nor how I chose the custom locations.  But after reading the Warning below that checkbox, I changed it back to the "recommended location".  Voila! - PL will now start and run when I boot Windows.

-->  My mistake originally, but I'd recommend that PL not fail silently when it can't (evidently) create its log file.

Thanks for a great product and the continued support.


If you has enable the UAC, I think this will happen. :)
But yes, it should showing some warning for this.


UAC was and is off (set on "Never Notify").

I've now rebooted about 5 times, and on all but one of them PL started OK.  So I am not sure I fixed the root problem, but it's working much better (as it used to).

Jeremy Collake

Thanks for reporting this, and updating us.

I am glad it is working better now, though it sounds like the problem is not solved.

I agree that it shouldn't fail silently. In fact, it shouldn't fail at all. The design intent was to allow complete failure of the log subsystem and things still rolled on. I will evaluate this error case and check safeties that are supposed to warn the user about this condition. That hasn't been tested in a while.

In the next beta version, I will be restoring minidumps. I don't know if there is any crash here, but if there is, please send this minidump. Of course, if the issue is indeed caused by what you surmise, then I should be able to replicate it.
Software Engineer. Bitsum LLC.


It would of been informative if you knew the folder location it was accidentally pointing too , sounds like a permission to write or something .

I just went through similar issue with some software , I installed new gimp2.8.6 and I had been editing a image file in another app dir before w/o issues .
With new version though all worked till I wanted to save , it gave error on saving . funny thing if I moved/copy file to desktop all went fine .
Now I set gimp to run as administrator and all is well . The thing is I am only user and I am administrator user so not sure why but anyway that is what fixed this .
Bitsum QA Engineer


Ya, so some game are putting their game file/launcher inside the "Users" folder for full access. :)


Well, looks like it wasn't permanently fixed.  After a day PL's GUI would no longer start with Windows (using the default startup settings).  So I have the workaround of telling the GUI to not start with Windows, and telling the core engine to not start until the GUI asks for it.  Then I put a shortcut to the GUI in my Windows Startup folder.

That has worked once now and probably will keep on working.


Jeremy Collake

Thanks for the update. That's no surprise.

When the GUI isn't running after a start, do you know if its process (processlasso.exe) exists or not? If, after a failed auto startup, you run Process Lasso manually and the main window pops up, but the system tray icon does NOT appear, then the process does exist, it has just lost its system tray icon. If the system tray icon appears when you manually start Process Lasso *after* a failed auto startup, then it wasn't running.

Have you checked the Windows application event log?
  - View Event Logs
   - Windows Logs
    - Application

Software Engineer. Bitsum LLC.


Hi Jeremy -

I switched back to the default settings on startup, which I had moved to per my original note but which then failed... and they seem to be working OK.  So I can't answer any of your questions.  If I have more trouble with startup I'll write again.

BTW, on the first reboot after changing to the default settings, the PL GUI opened and stayed open.  I figured that I had somehow changed a setting telling it to "start minimized", but then found that there is no such setting.  Not an issue unless that keeps up.



Jeremy Collake

Thanks Arbie!

I believe the main window showed up like that because of a crash, then automated restart by the error recovery mechanism.

This crash is probably what caused it to fail to start as well.

The difference in behavior is due to changes in the error handling code.

In beta versions, crash dumps are enabled. So, for those, you should see some indication of the crash. If you do see a crash dump message, send me the minidump (the message box should direct you to the minidump), then send it to me.
Software Engineer. Bitsum LLC.