Author Topic: Upon updating a "This program is blocked by group policy error is received.  (Read 5369 times)

Offline FL Jack

  • New
  • *
  • Posts: 2
 :-X
Upon automatic updating or updating through the link in the program for the last 3-4 or so versions of Process Lasso I receive the following error popups:

"C:\\Users\....\appdata\roaning\ProcessLasso\pl4sfx.exe

This Program is Blocked by Group Policy.  ....."

and after clicking the above message, I get the following popup:

"Process Lasso

Error launching updater!  Please update manually (1)"

I'm curious as this has only been an issue with last 3-4 recent versions.  It is possible that I may have done something to cause this, but have no idea what I may have done.

Is there a fix?

If I download and reinstall the program manually, there is no issue.

Thanks for your help.

I forgot to mention I'm using Windows 7 HE 64-bit.
« Last Edit: August 11, 2014, 01:19:28 PM by FL Jack »

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5414
  • Gender: Male
  • The Lasso
    • Bitsum
[redacted]

Cause ended up being CryptoPrevent. Need to white list 'pl4sfx.exe' in that software.
« Last Edit: August 12, 2014, 09:32:01 PM by support »
Software Engineer. Bitsum LLC.

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5414
  • Gender: Male
  • The Lasso
    • Bitsum
I am evaluating a new user registration problem with the forum, so received this from a user via email:

"I faced the problem too. And the culprit was CryptoPrevent. Myabe he has that program too. CryptoPrevent changes group policy settings to prevent ransmwares from running. What he should do is whitelist pl4sfx.exe."

Software Engineer. Bitsum LLC.

Offline FL Jack

  • New
  • *
  • Posts: 2
Thank you all for your input.

I am using CrytoPrevent, which I installed August 6th.  I've added the exe file to the white list as suggested and will see how it goes on the next Process Lasso program update. :)

Offline XhenEd

  • Member
  • ***
  • Posts: 40
Re: Upon updating a "This program is blocked by group policy error is received.
« Reply #4 on: September 22, 2014, 08:21:05 AM »
I just want to confirm that CryptoPrevent, by default, does block the update process of Process Lasso. I have reinstalled CryptoPrevent, so CryptoPrevent went default, erasing all whitelists. Forgetting to put pl4sfx.exe on the whitelist, an error occurred when updating Process Lasso to v7 (with the recommendation of PL to update manually or whitelist the .exe to CP). So, I whitelisted pl4sfx.exe again, and so the problem is gone and the update went successfully.


Kudos to the PL team to include a recommendation if the update went interrupted!

Actually, it was I who emailed support about the solution to the problem. I couldn't register at that time. So, to help, I decided to just email the support team to offer a suggestion.  ;)