NOTICE: Registration may require manual admin activation. After registering visit to request account activation.

Main Menu

Questions about default priorities

Started by rhoadesb, June 06, 2011, 06:13:25 PM

Previous topic - Next topic


Under options/configure default priorites I enter an executable name ... abc.exe for example. I set abc.exe as "below normal".

Sometimes abc.exe stays there a little while to a few hours then ... something takes it out of the list.

The time it takes for this to happen varies, but it ALWAYS within a few hours to a day ... or less, is removed from the list.

My questions:

What might be removing it?

How can I configure it not to be removed unless I remove it?

Thank you.


addendum to previous:

I am using verion I was using Under both, this is happening.

Jeremy Collake

Hmm, that is strange. Nothing should be taking it out of the list. It would seem that the configuration file is being reset somehow, though I am not immediately sure how this would occur, and haven't seen it myself in testing. I will review the logic paths and see if I can discover what is going on. Otherwise, my best guess would be:

If you run any registry or file system cleaner such as CCleaner, make sure it isn't accidentally deleting the Process Lasso files. Some of these programs get confused because the application "Process Lasso" uses an application data folder and registry key "ProcessLasso". Notice the lack of space in the name.
Software Engineer. Bitsum LLC.


Maxi Dice...;2

is the actual program. The main executable maxi dice.exe is the file in question ... if that helps to figure it out.

It seems to be a memory hog at times. I run it in a sandbox (Sandboxie) with no rights to access the internet.

Be careful as Sandboxie tells me that it is trying to simulate key strokes when I force it to shut down. That may be innocent, but I don't know.

Jeremy Collake

I don't think maxi dice is related to the problems, though I am still looking into things. A while back I wrote some code to detect when the settings were wiped out by an external program, so I will test and enable that in v5.0.0.27. It is possible I'll have it in v5.0.0.26, but I already have that undergoing final testing.
Software Engineer. Bitsum LLC.


I've been using the last couple days with the same results.

What can I do to assist you in determining what is causing the problem? I looked around for a log file. Maybe not in the correct location.

I'm using Windows Vista. When I installed Process Lasso I installed in in c:\users\public\programs\Process Lasso\ using admin. rights.

99% of the time I use a standard account. When I entered "maxi dice" it was as a standard user.

Jeremy Collake

I have fixed this in v5.0.0.28, finally. Thanks to a user report, I was able to track down the cause. Please give it a try, you should be pleased. It turned out to be a logic error in the GUI under XP when Terminal Services is disabled.
Software Engineer. Bitsum LLC.



I downloaded and installed a few hours ago.

If I do not update this thread, you will know it's working for me now.


I'm sorry to report it is still happening.

I also placed a test name in as "below normal", having nothing to do with Maxi Dice. It took the test configuration out upon reboot.

Jeremy Collake

Hmm, there must be something I am not understanding or am missing here then. Are ALL your settings reset, or is just that one lost?
Software Engineer. Bitsum LLC.


I did not think I had changed anything else, but to make sure, I first tried  "reset ALL configuration to default".  The system refused to allow this.

I then tried, using advanced tools to "Manually edit the current INI configuration file". The Windows Vista system then informed me that access was denied. This happened in both the standard and administrative accounts.


I uninstalled Process Lasso completely, then reinstalled it using it's default install directory, not the one I mentioned previously.

I then went in and set firefox as "normal" and maxi dice as "below normal" in Configure default  priorities. At that point I shut the PC down, restarted in the standard account and presto ... everything remained just as I had set it.

I think the problem is solved for me now.

As to the why of things ... you tell me.


Now ... the system will also allow reseting/editing the config file as well.

Jeremy Collake

Thanks for the info and testing! It looks like you did solve your own issue, though I am unsure how this occurred to start with.

It would seem that the configuration changes you made were never being saved at all because of the inability to access the configuration file. Did you use a global configuration file path override by chance? Otherwise, I am unsure how this could occur..
Software Engineer. Bitsum LLC.


"Did you use a global configuration file path override by chance?"

Maybe ... early on as I was learning to use the program. I can't be sure.

Jeremy Collake

Ok, I am going to do some experimentation and see if I can reproduce that scenario and see what I can do about it. At the very least, this problem should have been presented to you, instead of it being a mystery in the background. So, I will work on it ;).
Software Engineer. Bitsum LLC.