Lasso lets Program use only one core, when I open Lasso Window it jumps to all 8

Started by BalancedBear, October 03, 2018, 05:29:06 AM

Previous topic - Next topic


Hi there, I noticed (and I believe it hasn't been like that before) today that when I use Photomatix, it often only uses 1 core, taking ages. When I open the Lasso window to look there, it immediately jumps up to all 8 cores being used. The first 2 or 3 times I thought it's a coincidence but it isn't.
I had yesterday changed the core affinity from all 8 cores to core # 2 to 7 (leaving the first physical core alone). Can that be the reason? I changed it back to use all 8 cores, but the behaviour is still the same. When looking at the processes in Lasso, I see Rule "N0-7" written at the Photomatix process. And I see at Restraint "28 (14.03m)". Which settings are wrong, what can I do? Any specific info I need to provide?
cheers, BalancedBear


Thanks for the report, we will look into it.

If you remove core 0 from the affinity for that process in "always" setting you should see in the rules column "1-7".
That has nothing to do with restraint history, that is about Probalance and how many times it been restrained.
Bitsum QA Engineer

Jeremy Collake

Ed reproduced the issue.

It seems the 'always' CPU affinity is being enforced, over-riding your new current CPU affinity setting.

For the time being, you should either remove the 'always' CPU affinity setting by selecting 'CPU affinity / Always / NONE' (as opposed to setting all cores)  .... *or* use the Always CPU affinity to make a change to the current CPU affinity.
Software Engineer. Bitsum LLC.


Okay, thank you, I set it to "none" and will see tomorrow if that helps.

BTW, when clicking on "Show new replies to your posts" I get an error screen.


I still have this behaviour, that when Photomatix is doing something CPU hungry, I have one or two cores being at 100%, and seeing that it takes longer than usual. As soon as I click on another program (Lasso itself, or I saw that happening when I wanted to do the screenshot that I have now attached) suddenly the other 6 almost-idle cores jump also up to 100%, and the task progress bar in Photomatix (or in Lightroom) moves a lot faster.
I am new to Lasso, only have it for 10 days, but I am sure I can see that behaviour since I tried out some settings in Lasso a few days back. I deinstalled Lasso and installed it new, hoping it would be as before, but it seems whatever settings I made, are not getting deleted when deinstalling. :(
The moment the green CPU line goes up to 100% (all cores), after the third yellow bar, is exactly the moment I clicked on Lasso. Same as when I click SnippingTool or anything else.


That is weird, it is like it only runs full speed in a background mode.
On PL, if you close PL (both ProcessLasso.exe and ProcessGovernor.exe) then windows reverts to windows normal priority.

You can reset all settings to default with Options>reset all configuration to defaults but that will wipe all settings.
If you want to edit a certain type, like affinity or priority then just open that option for the whole list of processes you may have set.
Bitsum QA Engineer


Quote from: edkiefer on October 06, 2018, 08:42:10 AM
You can reset all settings to default with Options>reset all configuration to defaults but that will wipe all settings.
If you want to edit a certain type, like affinity or priority then just open that option for the whole list of processes you may have set.
I tried that, complete reset, but the behaviour is still the same. I noticed, that when I tell Photomatix to work, and I get only 2 cores running (not the same physical core), that it doesn't matter if Photomatix is in the foreground or not, to make this happen. And I don't have to switch to specifically to Photomatix or to Lasso, to get that reaction of suddenly all 8 cores get pumped. It's the switch itself, it seems, no matter to where.
BTW, it just occurred to me, does it matter, that I've got W10 Enterprise, not home or pro?


I don't think Win10 Enterprise would change anything PL supports all versions, even server.

That sounds like something hardcoded with Photomatix.

So for test close, PL, making sure both processes closed and then run Photomatix, does that change anything?
Bitsum QA Engineer


Hello again.
I tried to do a bit more of a scientific approach to the whole thing, and it looks like Lasso is not the cause, and can't help about it.

I checked the versions of Lasso and Photomatix, and they are both the current version (no beta).

I then, with Lasso running, loaded in Photomatix 3 pictures, and let it make a HDR version out of them. When done, I closed it. Did that 3 times.
1) I didn't touch anything and let Photomatix be the active window.  All 8 virtual cores were at 100%.
2) Immediately after starting the workflow in Photomatix, I switched to my browser. Only 2 cores were at 100% (this time, it were the two virtual of one physical).
3) As 2) but as soon as it was stuck with the 2 cores only I clicked to start Clipping Tool (just to see what happens, when not switching back to Photomatix, but to a third). As soon as I did that, I had all 8 cores at 100%

Then I stopped Lasso and Lasso Core Process, checked in Taskmanager that there was no Lasso to be found and did the same as above.


I was convinced that this behaviour only started a few days back, but that must have been rampant imagination on my part. :-/


Ok, Thanks for testing that all out.

Only thing I can think of is to see if Photomatix has a forum and see if this issue has been brought up.
Maybe there is a switch or option to stop it and use all cores always, then you could probably use PL affinity if needed.

Did quick Google search and only found an old post (2007)

and this FAQ

Not very helpful.
Bitsum QA Engineer


Hi there,
they have a good support team reachable via eMail. I've contacted them.
The fun is, in Photomatix is an option to tell the programm how many cores out of [core max] it can use. It is set to 8. :-/



Just an Update to issues mentioned by me and Jeremy, ver 9.0.502 fixes an odd issue with current options in affinity if you had set a value of always beforehand.
But this does not change the OP problem with Photomatix itself.

There are other fixes in .502 but just mentioning this as it was noted here.
Bitsum QA Engineer