Author Topic: Process Lasso Pro 9.1.068: Performance Mode not being set for Cubase  (Read 320 times)

Offline ranko

  • Basic
  • **
  • Posts: 12
I installed Prozess Lasso today as service.
I added also Steinbergs Cubase to the list of applications for which Performance Mode shall be enabled.
Cubase also has an internal option to set its own energy profile "Steinberg Audio Power".

I would have expected now that Process Lasso has precedence over the applications power profile setting and finally activates "Performance Mode" for the system. But this doesn't happen. In Process Lasso Window I see still "Steinberg Audio Power" enabled. And it stays even when I rightclick the Application and assign manually "Application Power Profile -> Bitsum Highest Performance".

As normal user I can change the Power profile with my Win7 Gadget that you already know and then balanced mode or energy saving mode is being displayed in the Process Lasso GUI as current power profile.

So by this I validated that Cubase does not instantly change back to its own power profile.

Question, why does Process Lasso Pro not properly set the Power Profile
a) automatically, because I added the path to the Cubase executeble properly to the list of designated high performance processes
b) after manually assigning the process Cubase9.5.exe "Bitsum Highest Performance" as Application Power Profile (rightclick with mouse to process)

Other check when disabling Cubase own power Profile: Bitsum highest Performance properly kicks in, if I configure Cubase not to use its own power profile which does different things including deactivation of CPU core parking. I wonder, why this deactication in Cubase is necessary. For my understanding Cubase only sets it one time on startup (otherwise I could not change it as user successfully with the power gadget) and then everything should be under the control of Process Lasso Pro.

Would be very nice if you could have a view on this, many thanks.



Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5244
  • Gender: Male
  • The Lasso
    • Bitsum
Re: Process Lasso Pro 9.1.068: Performance Mode not being set for Cubase
« Reply #1 on: June 09, 2019, 11:36:26 AM »
When an application changes its own settings, or the power profile in this case, Process Lasso doesn't try to fight with it. Instead, Process Lasso makes a one-time change.

'Options / Forced mode' (near the bottom) can relieve the conflict with many settings, but not in the case of power plans. The code needs adjusted to allow for forced mode with regard to power plans. This is something I'll consider going forward.

For the time being, it is simplest to disable CuBase's set of its custom power profile.
Software Engineer. Bitsum LLC.

Offline ranko

  • Basic
  • **
  • Posts: 12
Re: Process Lasso Pro 9.1.068: Performance Mode not being set for Cubase
« Reply #2 on: June 09, 2019, 02:52:42 PM »
Ok thanks, that you work on it.

I think a manual assignment of a powerprofile should somehow come into effect, otherwise the GUI operation would appear to be not working.

The workaround is fine by me.

And another aspekt .. Process Lasso is a tool about gathering more control about what is going on on the system,
not to do something only once and then to "close the eyes" and let application do.