News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

Just a heads up. Update loop again.

Started by noahphense, August 18, 2019, 01:07:20 AM

Previous topic - Next topic

noahphense

.31 still contains the .30 version data ..

edkiefer

Hmm, worked for me, but will look into.
Thanks for the report.

Edit: Just tried a VM as of 8:00 EST and .30 to .31beta updated fine to .31.
Bitsum QA Engineer

Jeremy Collake

#2
It appears that the QuickUpgrade module isn't being replaced in some circumstances, meaning a final->beta bug in 22 is persisting into 30. This was caused by the refactoring of the update settings.

I have now made a presumptive fix, but it won't self-correct until the next final update.

If you re-run the full installer, it will replace this file and you'll be good to go.

Thanks for letting us know!

Software Engineer. Bitsum LLC.

noahphense

Ok thanks guys, I would just keep doing it over and over again, with always an update to .31.  I'm sure it updated the core to .31, as in the other thread, except that it still thought it was an older version.  A few hours after reporting the issue, it didn't happen again, so I assume that it was able to grab an updated file.

With that said, I downloaded and installed a fresh version, which of course is a 'full' version.  Then updated it to the latest beta.  No issues.  I did noticed this difference though.  Not sure they are supposed to match.  Just throwing it out there.





Cheers.


Jeremy Collake

Probably the updater finally successfully replaced QuickUpgrade.exe to 30, then it could update to 31 beta, and did.

The same replacement failure is what is causing it to now be stuck at 30.
Software Engineer. Bitsum LLC.