Author Topic: How to disable IdleSaver from CPUBalance?  (Read 277 times)

Offline joek

  • New
  • *
  • Posts: 3
How to disable IdleSaver from CPUBalance?
« on: November 30, 2019, 06:16:31 PM »
Hello, i have a problem when using both CPUbalance and ParkControl.

I use the "Bitsum Highest Performance" profile working full time, no need to use dynamic boost option.

But when i install the CPUbalance it use the IdleSaver in-built to keep changing to balanced profile after some seconds. i tried checking the option "Disable CPU Core Parking during Pro Balance restraint" but nothing changed.

then how to?

I use it on Windows 7 x64.



Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1708
  • Gender: Male
Re: How to disable IdleSaver from CPUBalance?
« Reply #1 on: November 30, 2019, 08:27:16 PM »
Hello, i have a problem when using both CPUbalance and ParkControl.

I use the "Bitsum Highest Performance" profile working full time, no need to use dynamic boost option.

But when i install the CPUbalance it use the IdleSaver in-built to keep changing to balanced profile after some seconds. i tried checking the option "Disable CPU Core Parking during Pro Balance restraint" but nothing changed.

then how to?

I use it on Windows 7 x64.
Idlesaver is part of Process lasso, did you install it prior to CPU Balance?
In Park corntrol uncheck "Bitsum dynamic boost enabled" If you still see power plans change toggle the dynamic boost setting on/off to see if that helps.

Edit:

GO to "C:\Users\[user name]\AppData\Roaming\ProcessLasso\config" open file prolasso.ini and at the bottom look for this [PowerSaver] section, then make below line false.

[PowerSaver]
 
EnergySaverEnabled=false
Bitsum QA Engineer

Offline joek

  • New
  • *
  • Posts: 3
Re: How to disable IdleSaver from CPUBalance?
« Reply #2 on: November 30, 2019, 10:32:16 PM »

GO to "C:\Users\[user name]\AppData\Roaming\ProcessLasso\config" open file prolasso.ini and at the bottom look for this [PowerSaver] section, then make below line false.

[PowerSaver]
 
EnergySaverEnabled=false

This worked, thank you.

Offline joek

  • New
  • *
  • Posts: 3
Re: How to disable IdleSaver from CPUBalance?
« Reply #3 on: December 01, 2019, 01:05:26 AM »
Only but one question, what purprose of this option: Disable CPU Core Parking during Pro Balance restraint


Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1708
  • Gender: Male
Re: How to disable IdleSaver from CPUBalance?
« Reply #4 on: December 01, 2019, 01:12:05 AM »
Only but one question, what purprose of this option: Disable CPU Core Parking during Pro Balance restraint
What that would be for is if you want/use core parking, then when a process is restraint it would then disable parking so you have more cores ready.
It should help in response time.
Do note BHP and AFAIK HP has core parking disabled in Win10, I think it is still enabled in Win7 with HP power plan but I would have to check.
Bitsum QA Engineer

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5249
  • Gender: Male
  • The Lasso
    • Bitsum
Re: How to disable IdleSaver from CPUBalance?
« Reply #5 on: December 01, 2019, 11:05:47 AM »
The system High Performance (HP) power plan may or may not have CPU core parking disabled by default. It depends on the CPU, OEM and form factor. Usually it has core parking enabled, hence the need for Bitsum Highest Performance (BHP).

'Disable CPU core parking during ProBalance restraint' does exactly that. During a ProBalance event, if CPU parking is not already disabled by the active power plan, it will be temporarily disabled. I don't recommend using this option due to the overhead in making that change though. Instead, you should use 'Performance mode' (marking processes to 'Induce Performance Mode'), which engages the Bitsum Highest Performance power plan.
Software Engineer. Bitsum LLC.