Bitsum Community Forum

General Category => Process Lasso => Topic started by: edkiefer on May 02, 2014, 11:01:36 PM

Title: Default power profile not being restored [FIXED]
Post by: edkiefer on May 02, 2014, 11:01:36 PM
running 6.7.0..55b and noticed after a process with power profile set to HP , when closing this process the power profile is not going back to default .

Log says restoring previous power profile of  HP power profile, instead of my default (custom power profile )which was the real previous power profile .
Title: Re: Default power profile not being restored
Post by: edkiefer on May 03, 2014, 07:25:17 AM
Ok, I think I see whats going on, seems to be conflict with game mode and power profiles .
example , setup calc.exe for power profile HP , start with balanced profile .
works fine , goes to HP when running and returns to balanced .

Now add calc.exe to game mode and it doesn't switch back to default (balanced) stays on HP even after closed.
Title: Re: Default power profile not being restored
Post by: BenYeeHua on May 03, 2014, 05:36:02 PM
Yup, confirm here. :)
So I guess it start happen in this beta?

Quote
6.7.0.55[beta]   Change   Core   Revert to older behavior of Gaming/Multimedia mode. (work in progress)
Title: Re: Default power profile not being restored
Post by: edkiefer on May 03, 2014, 06:42:05 PM
yes, seems changes were made to game mode .
Title: Re: Default power profile not being restored
Post by: Jeremy Collake on May 13, 2014, 12:05:42 PM
Yes, you deduced correctly. Gaming Mode again sets High Performance power profile, like it used to, before application power profiles took it's place. This does cause an inherent conflict with other features that adjust the power profile. I am still working on how to best deal with this issue.
Title: Re: Default power profile not being restored
Post by: edkiefer on May 13, 2014, 12:56:36 PM
Ah , you should of said that, I didn't test game mode by itself.
Most app I have in power profile are for HP use with games  :D
Title: Re: Default power profile not being restored
Post by: edkiefer on May 13, 2014, 04:02:16 PM
Just thinking off top of my head .
Maybe combine game mode and power profiles into a App tune/mode were you pick app like in both previous modes but have all options to set for that app .
kind of what you did with Watchdog rules over time .
Title: Re: Default power profile not being restored
Post by: edkiefer on June 07, 2014, 08:07:56 PM
Update: beta 6.7.0.67b still has conflict between power profiles and game mode .
Title: Re: Default power profile not being restored
Post by: Jeremy Collake on June 07, 2014, 10:26:33 PM
Yes, my prior idea on the change in behavior a terrible one -- or, more precisely, was not mature enough to have been released.

I am reverting that change.
Title: Re: Default power profile not being restored
Post by: Jeremy Collake on June 07, 2014, 11:19:00 PM
I have reverted it in v6.8.0.1. It should now function in a way you'd expect.
Title: Re: Default power profile not being restored
Post by: edkiefer on June 08, 2014, 03:06:33 AM
 v6.8.0.1. seems to be working .
Title: Re: Default power profile not being restored
Post by: Jeremy Collake on July 05, 2014, 06:49:35 PM
Thanks for the confirmation Ed!

I am slowly simplifying the product.

I will have news about stuff I've been working on some time soon. I can't say anything else for now.