Bitsum Community Forum

General Category => Bug Reports => Process Lasso => Resolved Bug Reports => Topic started by: Montgomery on June 29, 2015, 09:32:36 AM

Title: ProcessLasso TCP connection left in CLOSE_WAIT state [FIXED 8.5.0.5 beta]
Post by: Montgomery on June 29, 2015, 09:32:36 AM
Hi,

Process Lasso 8.2.0.4 x64 on Windows 7 x64
-
1- Even though I've opted for Updates:Never every new Windows session shows ProcessLasso.exe having opened a TCP connection to Remote:www.bitsum.com
I assume this is the updater function.

2- If I don't close it myself this connection remains.

Thanks.
Title: Re: ProcessLasso updating and connection remaining
Post by: edkiefer on June 29, 2015, 09:55:48 AM
But its State = close_wait , so its not doing anything .
Title: Re: ProcessLasso updating and connection remaining
Post by: Montgomery on June 29, 2015, 10:38:46 AM
1- I denied auto-update, so no connection should be done to bitsum ;
2- A "Close Wait" connection that doesn't close after the nominal delay is not normal ;
3- It's not because a process doesn't harm that its inconsistency when applicable is not worth being mentioned.
Title: Re: ProcessLasso updating and connection remaining
Post by: Jeremy Collake on July 02, 2015, 11:04:15 PM
This is something we had reported last month, but I haven't had a chance to look into it. I believe the connection isn't properly cleaned up. I am building 8.4 final now, which will behave the same, but will be sure to get this addressed in future versions.

I hate to speculate on what is going on, but these things are certain:


Topic moved to bug reports and I'll be tracking this closely. I may very well release a beta that resolves it in the coming day(s). Once I've tracked down the precise cause, I'll be able to tell you why it happened, etc...

Thanks for the report!

Apologies for the problem, and I'll post here when I have it resolved!

And smart move running dnscrypt-proxy, I have tried to encourage as many people as possible to do the same. It's amazing that so few people consider the lack of DNS query encryption a serious issue.
Title: Re: ProcessLasso updating and connection remaining
Post by: Montgomery on July 03, 2015, 12:49:11 PM
Thanks for acknowledging. I understand it'n in no way a privacy issue, not with Bitsum. I was and remain puzzled but aware it's most likely nothing more than an unclosed switch, somewhere. No problem.

Process Lasso getting better, smarter and stronger at every update. Enjoying it like all of those who've tried it.

And the beat lasso goes on :)

EDIT : I had to initiate a new registration because I had closed previous one (above) a day I was in a bad mood... sorry for the disturbance.
Title: Re: ProcessLasso updating and connection remaining
Post by: Jeremy Collake on July 03, 2015, 05:19:06 PM
Glad to have you back, and apologies for my late reply! I am so often deep into product dev and leave the forum to others for a few days.

I'll have an answer/fix for this very soon... maybe tonight.
Title: Re: ProcessLasso updating and connection remaining
Post by: BenYeeHua on July 04, 2015, 02:17:34 AM
Quote
And smart move running dnscrypt-proxy, I have tried to encourage as many people as possible to do the same. It's amazing that so few people consider the lack of DNS query encryption a serious issue.
Well, In china, some people are using it, and you know why. ;)
Title: Re: ProcessLasso updating and connection remaining
Post by: Jeremy Collake on July 05, 2015, 03:41:45 PM
So it appears the cause here was NOT the update check -- that is why the updates off setting didn't matter.

It's a connectivity check I added a few versions ago that didn't properly close it's internet handle.

In this case, a call is made to simply see if Bitsum's servers are accessible by accessing https://bitsum.com/check.html before attempting to show you an offer to purchase a license (even for licensed users, as the 'already activated' check is later).

It will be fixed in v8.5.0.5 beta, coming in hours at latest.
Title: Re: ProcessLasso updating and connection remaining
Post by: edkiefer on July 05, 2015, 05:31:58 PM
fixed confirmed in v8.5.0.5 beta , even with updates on .
Title: Re: ProcessLasso updating and connection remaining
Post by: Jeremy Collake on July 05, 2015, 05:33:06 PM
Thanks Ed!
Title: Re: ProcessLasso TCP connection left in CLOSE_WAIT state [FIXED 8.5.0.5 beta]
Post by: Montgomery on July 06, 2015, 12:46:17 PM
This tiny non-issue in fact was related to a connectivity check and not to the update check : OK

I'm no specialist (I eat without cooking!) but I imagine this type of tiny little bug with no incidence whatsoever on the program itself can be the toughest to find precisely because it is not in a heavy cause to consequence scheme...

So, my wandering made Jeremy land on a small ratio consequence/cause brain exercise :) Anyway, happy to know the origin has ben spotted and solved with PL 8.5.5.5 beta, and thanks for having taken the time to resolve what was obviously not a flaw at all.