Randomly stops working, no longer identifies out of control or disallowed

Started by reddevil7nine, November 25, 2008, 12:20:41 AM

Previous topic - Next topic


I've been using process lasso for a week or so now and i've noticed that it seems to stop working. doesn't recognize out of control processes nor processes i've put in my disallow list. no errors, no warnings, just doesn't do anything.

i've got to exit out of the app and then kill the governor from task manager and then start the app over again.

is this a known issue? i really like the idea of this software but if it keeps going like this, it's pretty useless to me.

vista ultimate, 64-bit

Jeremy Collake

This isn't something I've ever seen or heard happen before. However, I do believe its happening to you, so I would like to discover why and issue a fix if necessary.

A few questions: Have you changed the default configuration in any way? Can you send me your configuration file (INI) so that I can take a look? Is the governor still running when it 'stops working'? There is also a test app with Process Lasso, if you ever need to test if ProBalance is working or not.

Thanks for reporting this, I'll do my best to figure out what is happening on your system.
Software Engineer. Bitsum LLC.


thank you for the eagerness, really nice to see, especially for a free software.

by changing the default configuration if you mean have i changed any settings, a few yes, here is my ini file:

PlayOnRestraint=C:\WINDOWS\media\Windows Battery Critical.wav
PlayOnRestore=C:\WINDOWS\media\Windows Battery Low.wav
DefaultPriorities=eraserl.exe,idle,java.exe,above normal,javac.exe,above normal,javaw.exe,above normal,sidebar.exe,below normal,procexp.exe,below normal,procexp64.exe,below normal,cdbxpp.exe,high

the governor is still running when process lasso stops doing anything. yes, i have also tried the test app and it always says "process lasso doesn't seem to be working, did you click on a different window."

if i close process lasso and restart the governor as well, all is working again.

Jeremy Collake

Ok, thanks. I'll be evaluating this in detail as soon as I can, probably today.

In the meantime, you may want to try turning off the systray balloon notifications. That will be the first thing I will look into as a possible cause of the hang you see.
Software Engineer. Bitsum LLC.



Have you had a chance to look at this issue? Is there something else i can send to help you with it?

I've turned off the balloon notifications and that didn't seem to have any affect.

Jeremy Collake

No, I'm still evaluating this issue, attempting to reproduce it. It may be specific to the x64 build, as I do less long-term testing with it. I I apologize for the inconvenience.

Is there any log action the governor records prior to it stopping working? If there is a pattern, with it stopping after performing a process termination or restraint prior to restraint, it will help me narrow down where it's getting confused.

I may need to publish a debug build for you to use, if willing. Looking at its debug log should show where it stopped performing and I'll be able to isolate the cause much faster (hopefully).

Thanks, and I'm sorry again.
Software Engineer. Bitsum LLC.


doesn't seem to be a pattern, there isn't a single process that is logged before it stops working each time.

if you think a debug build would help, i'd be willing to give it a try for you.

Jeremy Collake

Ok, thanks.

I will publish the debug build here: http://www.bitsum.com/files/internal/pssetup64.zip . You have to use SysInteral's (now Microsoft's) DebugView application to view the debug output. You can then send me a log, or analyze it yourself. It should help to show what is going on.

I have not published the x64 debug build before, so give me a couple hours (from this post) to get the latest version up there.

Incidentally, if you get fed up, you may also wish to try the x32 build of Process Lasso. While it isn't designed for x64 systems, it will work on them as a WoW64 process.

Thanks for your assistance.
Software Engineer. Bitsum LLC.


how would you like me to log? start debugview before process lasso and log until it stops filtering apps or start debugview after process lasso has stopped filtering apps and just log for a few minutes?

i might give the 32-bit version a try as well, thanks!

Jeremy Collake

First, I should mention that I'm only really interested in the debug output of processgovernor.exe, so you can exclude processlasso.exe from the log (or I can filter here).

And, yes, I'm interested in the log events before and during the failure to continue working. It will hopefully let me know what the last action taken is.

Actually... I think I want to add some more debug output to the governor, as it may not currently be granular enough to let me know what is happening. I'm going to do this today, if you want to wait a little while.

Software Engineer. Bitsum LLC.


i sent you an e-mail via the forum software with the logs text, we'll see how that works.

i'll give the other build a try when you've got it sorted out.

Jeremy Collake

Ok, thanks. Btw, I'm suspecting it could possible be a logging issue. That is one area where a hang could occur since accesses to it are synchronized.

I've also posted a new build as of now, it emits much more debugging information than the previous. The URL is the same, and to be sure you don't get a cached copy, the version is 3.29.2.

Software Engineer. Bitsum LLC.


either i can't get passed the cached file (i've tried several tricks) or maybe you forgot to copy over the latest version? ???

the version i'm downloading says, not 3.29.2

Jeremy Collake

Does it say that in the about box, or the file/install version? Sometimes I forget to update the latter, especially on quick builds. I tested it, and it appears to be the right one.

I put it at a version-specific link here: http://www.bitsum.com/files/internal/pssetup64_3292.zip , that should fix any caching issues at any level . A log from this version will be much more useful than that of the previous version you had sent. I'm sorry you went to the trouble on the first build, that was all I had initially available.. and rushed to get this better one out.

Software Engineer. Bitsum LLC.


not a problem, i'll get this installed soon and pass on the log.

you're right, it was the file version, not the about  :-[

Jeremy Collake

I am pushing out a new final, so I'm posting a debug build of v3.30 at same url (http://www.bitsum.com/files/internal/pssetup64.zip). It fixes an issue in the last debug build where you may have been flooded with 'new foreground detected' messages. They now are only emitted when the foreground really does change ;).

As soon as I figure out your issue, I'll get it addressed and release a new final right away.

Software Engineer. Bitsum LLC.