News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

[Build] Unable to build Firmware Mod Kit - Linux Mint Debian

Started by KazzaMozz, October 31, 2012, 05:27:40 PM

Previous topic - Next topic

KazzaMozz

Hi Everyone,
I have posted this in a reply to another person with a similar problem.  As it's an old post as per the suggestion I am posting it as a new topic.
My Post
Hope someone can help as I'm not the only one it seems with this issue.
Cheers
KazzaMozz

BenYeeHua


KazzaMozz

Hi there
For the record zlib1g-dev is installed and all dependencies.
It's not a dependency error I am getting it's a make error. All dependencies have been met.
Scoured the internet read all the instructions.
Did you look at the dump with the errors ?
Running ./configure all boxes are ticked.  The problem is running the make command.
Cheers
Kazza


KazzaMozz

HI there
thanks for your reply
the zlib1g-dev is the latest and the correct one.
I will look at your other link and see what's in that as it appears it's more related to an error under
Squashfs-tools.  I did find a post relating to this in one of my searches stating there was an error in one of the makefiles but this is supposed to have been fixed.
If I can find it again I will post the link in here.
Cheers

KazzaMozz

Quote from: BenYeeHua on November 01, 2012, 09:38:01 AM
http://code.metager.de/source/xref/linux/utils/squashfs-tools/squashfs-tools/lzma_xz_wrapper.c
Hi there
This above link appears to be down or is not working for me the page can't load and I can't retrieve anything via terminal either.
I did a search and none of the links in the browser are working either.
Okay so I have located the xz-lzma and xz-utils through synaptic and they are installed.  I will install lzma and lzma-dev which removes the xz-lzma and hopefully it fixes it. Also any liblzma etc.  I will post the exact ones if it works.
In the errors it's relating to the lzma so I know it's in there somewhere that the problem resides.
Thanks

KazzaMozz

Hi there
I now have a built firmware-mod-kit. It is a later version than yesterday (fabulous)
Seems Debian installs a xz-lzma when it needs lzma.
The others I added just to be sure were
liblz1
liblz-dev
python-lzma (not sure if this was required)
xz-utils (already was installed reinstalled it)
liblzma-dev (I think this was already installed)
Anyway it it now works after
./configure
make
I have successfully extracted my firmware.
Great program

Cheers