News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

Cannot get the the firmware mod kit to work with Ubuntu

Started by Lucian_rider, April 13, 2009, 06:58:25 PM

Previous topic - Next topic

Lucian_rider

Hi,

I have a new 13" MacBook and via Parallels 4 I have created a virtual machine and installed Ununtu. The install is fully up to date and as far as I can see I have all of the dependencies installed include going so far as to do an apt-get of build essentials.

But I keep getting an error indicating that there is probably a dependency problem. Here is a cut and paste of what I am doing and what I get:

chris@chris-laptop:/tmp/firmmod$ ls
bins                        extract_firmware.sh           ipkg_remove_all.sh
build_firmware.sh           extract.log                   ipkg_remove.sh
check_for_upgrade.sh        firmware_mod_kit.htm          shared.inc
cleanup.sh                  firmware_mod_kit_version.txt  test-cases.txt
creating_ipkg_packages.htm  ipkg_install_all.sh
ddwrt.bin                   ipkg_install.sh
chris@chris-laptop:/tmp/firmmod$ ./extract_firmware.sh ddwrt.bin bins/

Firmware Mod Kit (extract) v0.62 beta, (c)2008 Jeremy Collake
http://www.bitsum.com
Checking for updates ...
  You have the latest version of this kit.
LINUX system detected. Compatibility ok.
Testing file system of bins/ ...
WARNING: You must be 'root' when extracting and building some images.
          This is because some images need to create devices in your fs.
          For DD-WRT, do NOT extract or build as root, use standard user.
Building tools ...
ERROR - Build did not succeed. Check log file, you are probably
         missing one or more necessary pre-requisites. See docs for
         a list of pre-requsites.
chris@chris-laptop:/tmp/firmmod$

I have tried having the files in my home, I have also checked the permissions but I keep getting the same error.

The Checklog file is basically empty with on the following:
make: *** src: No such file or directory.  Stop.

I have also tried using the Firmware mod under OSX after installing  X11. This gives me the exact same problem!!!

I'm pulling my hair out here. I would really appreciate some help so I can get this working.

Lucian_rider

I'm very surprised that no one had any comment as to what other dependencies are needed. Well I finally figured out that I needed to install the zlibc and the zlib1 pacakages. After that it worked fine...

DeepBlueDiver

I just installed FMK on Ubuntu (Intrepid), and had to install lib1g-dev for the tool to build successfully.

glenbush

I am having the same issues and can not get it to work. I have tried installing the lib packages and still nothing. Can somone please help.
Also if anyone knows how to edit the wifidog.conf file please let me know.
Thanks