Cannot get the the firmware mod kit to work with Ubuntu

Started by Lucian_rider, April 13, 2009, 06:58:25 PM

Previous topic - Next topic



I have a new 13" MacBook and via Parallels 4 I have created a virtual machine and installed Ununtu. The install is fully up to date and as far as I can see I have all of the dependencies installed include going so far as to do an apt-get of build essentials.

But I keep getting an error indicating that there is probably a dependency problem. Here is a cut and paste of what I am doing and what I get:

chris@chris-laptop:/tmp/firmmod$ ls
bins                          extract.log                 firmware_mod_kit.htm                  firmware_mod_kit_version.txt  test-cases.txt
chris@chris-laptop:/tmp/firmmod$ ./ ddwrt.bin bins/

Firmware Mod Kit (extract) v0.62 beta, (c)2008 Jeremy Collake
Checking for updates ...
  You have the latest version of this kit.
LINUX system detected. Compatibility ok.
Testing file system of bins/ ...
WARNING: You must be 'root' when extracting and building some images.
          This is because some images need to create devices in your fs.
          For DD-WRT, do NOT extract or build as root, use standard user.
Building tools ...
ERROR - Build did not succeed. Check log file, you are probably
         missing one or more necessary pre-requisites. See docs for
         a list of pre-requsites.

I have tried having the files in my home, I have also checked the permissions but I keep getting the same error.

The Checklog file is basically empty with on the following:
make: *** src: No such file or directory.  Stop.

I have also tried using the Firmware mod under OSX after installing  X11. This gives me the exact same problem!!!

I'm pulling my hair out here. I would really appreciate some help so I can get this working.


I'm very surprised that no one had any comment as to what other dependencies are needed. Well I finally figured out that I needed to install the zlibc and the zlib1 pacakages. After that it worked fine...


I just installed FMK on Ubuntu (Intrepid), and had to install lib1g-dev for the tool to build successfully.


I am having the same issues and can not get it to work. I have tried installing the lib packages and still nothing. Can somone please help.
Also if anyone knows how to edit the wifidog.conf file please let me know.