News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

CPU core use graph does not show, windows 64 pro [FIXED]

Started by MickeyG, July 07, 2013, 01:10:17 PM

Previous topic - Next topic

smartbit

Regarding the Extensible Counter List, I checked this one

I reviewed all the listings, and the only thing that has Performance Counters Disabled for it is Outlook.
All others are enabled.

So seems like it is not the issue.

Jeremy Collake

Darn in, I'll need to upload a new build. The extended output isn't being invoked. :o
Software Engineer. Bitsum LLC.

Jeremy Collake

I uploaded a new build that should show the additional debug info, but haven't incremented the listed version # on the server, so you'll have to manual install, or wait until I do update it. Sorry about that!
Software Engineer. Bitsum LLC.

smartbit

OK, yet another test performed, using the updated beta:

00000001 0.00000000 [20080] Process Lasso: adding \Processor(0)\% Processor Time
00000002 0.31620243 [20080] Process Lasso: PdhAddEnglishCounter failed cu - PdhStatus=0xC0000BB8, GetLastError=0x57
00000003 0.31712788 [20080] Process Lasso: The specified object was not found on the computer.
00000004 0.31712788 [20080]


4 lines of code by PL this time (the last one is empty)
I hope there is some useful info in it this time...

BenYeeHua

Yup.
0xC0000BB8 (PDH_CSTATUS_NO_OBJECT)   The specified object is not found on the system.
QuoteThe specified computer was found, but the specified performance object was found on the computer. If this status is returned when the counter is being added, the specified counter is not included in the query. If this status is returned by an active counter, the data for that counter is invalid. Each time the data is requested, PDH tries to obtain this counter data.
http://msdn.microsoft.com/en-us/library/windows/desktop/aa371894%28v=vs.85%29.aspx

And I only found 1 person facing this same issues.
http://social.msdn.microsoft.com/forums/wpapps/en-us/b23f79d8-1376-4398-ae97-ed8d3753b759/pdhaddcounter-and-pdhaddenglishcounter-returning-pdhcstatusnoobject-error-but-the-counter-object

I also found a new tools.
http://www.autoitscript.com/forum/topic/90736-performance-counters-in-windows-measure-process-cpu-network-disk-usage/

And I don't think it is some optimize software disabled by using the registry "Disable Performance Counters", right?

smartbit

Fixed!!! :)

I found the problem, I dug deeper on the 0xC0000BB8 error, some peope had this error for perfom.exe. Then, turned out that perfmon.exe also reported counters errors on this PC...
And eventually found this thread: <a href="http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/perfmon-problems-unable-to-add-counters/e90f231d-0014-457d-8b1f-5f342971597a">Unable to add counters</a>.

It recommended there to run "lodctr /r" in cmd to rebuilt performance counter settings to the initial state. (btw, "lodctr /q" gives similar results as the "Extensible Counter List" tool discussed before, querying the states).

And the "lodctr /r" fix worked, I verified that the counters are still at least as enabled in "lodctr /q" as before. But this time, perfmon.exe worked smoothly, then I tried PL v.14 (latest stable build)....
... and it worked!!!

The CPU graphs are there, a column for each (virtual) core!  8)
I compared the reported core states with the Resource Monitor, all matches.

The weird thing though, is that "Official Support" guy suggested this from the beginning. Following the suggestion, I checked the Resource Monitor and some other third party Performance  Monitors that reported core stated, and other detailed performance info, and it always worked just fine.
So I assumed that the background mechanism is the same, and if "Resource Monitor" is operational, then all other SW should be able to access the same data as well.
Turned out to be false assumption, as eventually, Resource Monitor can work perfectly, while PerfMon and Process Lasso (probably some others too) may not.

This is something to keep in mind for further possible issues it this area.


Well sometimes it end up a windows/config issue after all (which i guess is something to expect in the cases of system tools as Process Lasso).

Anyways, thanks a lot to everybody for the time, efforts, support and debugging assistance. ;)

Jeremy Collake

Awesome! Thanks so much for your testing and research smartbit!

This is great news... Now I'll see about auto-repairing the situation, if I'm able to determine the exact tweak that would be necessary. I maybe could run 'lodctr /r', but that seems a bit heavy handed.

I would have also expected Resource Monitor to fail if the applicable performance counters were disabled, it's interesting that it didn't. I'm not sure if ResMon is using different performance counters, it needs further research.
Software Engineer. Bitsum LLC.

edkiefer

you never know , anyway copy fix an add it to FAQ type info here .

I am sure this will come up again  :)
Bitsum QA Engineer

Jeremy Collake

What I will do is this:

When this exact failure occurs, I will give the user the option to have Lasso launch 'lodctr.exe /R' to repair the performance counters.
Software Engineer. Bitsum LLC.

smartbit

You're welcome  :)

I'm not sure you intend to include the "auto-fixing" in the installation process, or as optional fix,
but I'll suggest caution in using "lodctr /r".
It has been stated that it: "rebuilds performance counter setting from system backup store".

Whatever is meant by that, it may reset some settings that are differentiate from the initial state by desire, hence causing something else to fail.
(In my case, I didn't saw any negative impact or configuration loss. So far at least..)

So, I'd recommend to fully understand what modifications it incorporates, and the possible impact of those.

(Maybe adding a warning message for the user regarding the changes that are about to be made during the "auto-fix" may be a good idea).

Edit: last post appeared while I was just typing...
         Your last suggestion sounds like a good idea

BenYeeHua

Yup, I guess it is just better to showing a windows and said about this, then let the user to choose that want to fix it or not.

And I wonder how can it be corrupt for you? :)

Jeremy Collake

I believe the damage is in the registry, so it's possible a registry cleaner could have caused this damage. The actual performance counters were never disabled, they were just inaccessible when referenced by name.

I'd love to find out. Any clues, smartbit?
Software Engineer. Bitsum LLC.

BenYeeHua

Yup, it can be the registry.
QuoteIf you use the lodctr /r command, you will overwrite all Performance counter registry settings and Explain text, replacing them with the configuration defined in the file specified.
http://technet.microsoft.com/en-us/library/bb490926.aspx (http://technet.microsoft.com/en-us/library/bb490926.aspx)

smartbit

While I was looking for the solution, there were some solutions suggesting to modify a few registry keys instead of running "lodctr", but the purpose was the same.
And since the Registry jungle is window's way of keeping settings, it makes a perfect sense that the performance counters config is there and can be modified directly by 3rd party.

Regardin registry cleaning, well, I do use CCleaner occasionally to clean the temp folders, and also to scan & clean the registry.
Mainly the registry fixes include various invalid installation files locations, unused file types, etc.
But I use the same practice of regular cleaning on few other PCs, which has never had this issue with PL's CPU graph disappearing.

Since I use this laptop PC (the one that had the graph problem) as my main PC for many months now, many many software has come and gone through it. I frequently do various kinds of IT tech support at work/studies. So I use many kinds of tools for it, and it's not always possible to test stuff in a virtual environment, so in many cases I have to test it on my PC, until I find the proper tool for the job. So, even though I always try to pay attention at any modifications done by those "guests", it still very much may be that some other program messed up a few things.

Also it worth noting, that this laptop has a "Lenovo Enhanced Experience 3 for Windows 7" (aka EE3). Which is a lenovo's way of tweaking windows registry and settings to improve boot times, response and similar optimizations. Usually EE1-3 has pretty fine reputation, but who knows..

To sum things up, it may be the CCleaner, it may be the EE3, or it may be some other soft's work - personally, I tend towards the last option (other soft mess up).

Sorry for not being able to provide anything in specific.

edkiefer

CCleaner is pretty good, safe cleaner but I never remove/delete/fix anything that I don't know 100% whats going on .
I rather leave item than take chance and i don't enable all options anyway .
The file type one to me is waste to enable as it will just keep adding depending on file extensions used .

I only clean entrees I think may cause conflicts or if I check for left overs of a app uninstall .
Bitsum QA Engineer

BenYeeHua

Yup, I will say it is Lenovo, Asus software also playing with powerplan, disable core-parking etc.

smartbit

Disabling core parking has nothing to do with the inability to access performance counters.

Lenovo has its Power Manager to manage power plans, using which you can disable core parking, same as Windows Power Settings, only in more organized way.

What I was talking about is its' EE-labeled registry tweaks they do to speed up boot times. (Usually it involves balancing "delayed start" settings for unnecessary services, and should not have negative impact, but who knows)

And again, I tend to believe that the corrupt has been done by some other performance analyzers I've tried on this PC and removed later.

BenYeeHua

Who know, Asus also "port" the Power4Gear code to the TouchPad, disable core-parking and also "Force" high performance all the time...
It don't matter what's your PowerPlan, it just change your current PowerPlan to High Performance setting, after you un-plug the Power source.
Even they doing this, they has passed Energy Star...

If they can "port" the bad code to any software that don't has any function that is the same, I believe they can also corrupt Registry setting too.

At least I can believe the Lenovo software, as I using it for awhile, no issues when I using it, but Asus!?
No ways!
------
And it is also funny that performance analyzers will like to changing the registry setting, but forgot to change it back after uninstall it.

It will be great if you has the corrupt registry setting back-up, so at least we know which software is causing it. :)

edkiefer

Yes, if you try an do a compare of backup reg to see what changed or what part of reg changed might be helpful .


It still don't tell what app changed it .

I can see some "turbo" type optimizer , that disables services it thinks are not needed , problem is know one knows that question but user based on his/here app usage .
Bitsum QA Engineer

smartbit

Quote from: BenYeeHua on December 12, 2013, 07:04:52 AM
... It will be great if you has the corrupt registry setting back-up, so at least we know which software is causing it. :) ...

Good idea here, I actually have a pretty recent system image (before the fix) done by windows backup/restore.

Maybe any of you have in mind some quick way of extracting the registry from it without actually having to restore the image?

edkiefer

doesn't windows store last 5 days of registry ?

Guess not in last few OS's , seems there now stored in "C:\Windows\System32\config"
with each section having its own file .

Not sure if there way to read system restore points .
Bitsum QA Engineer

Jeremy Collake

I'm sure you could access the registry hives in a restore point, they are probably stored as hive files and can be loaded via the standard Windows registry APIs. I'm not sure anyone has ever done this though.

Process Lasso v6.7.0.27+ runs 'lodctr.exe /r' automatically when this specific error is encountered. This operation should be safe since it is a simple repair of the registered performance counters.

I'm glad we finally found the cause of the failure!
Software Engineer. Bitsum LLC.

BenYeeHua

Yup, thanks smartbit for finding that solution. ;)

For the backup registry, I has no idea yet, it look like no one know how to read from it.
---
http://superuser.com/questions/476105/is-registry-restored-after-a-system-restore (http://superuser.com/questions/476105/is-registry-restored-after-a-system-restore)
http://support.microsoft.com/kb/307545 (http://support.microsoft.com/kb/307545)

I guess this is the answer to get it? :)

smartbit

Hi guys,

I've spent some time digging the registry.
As suggested, there are actually a backup registry files at "C:\Windows\System32\config\RegBack", which were dated a day prior to the fix.

I also found some tool to read the registry hives without importing them locally: <a href="http://www.gaijin.at/en/dlregview.php">RegistryViewer</a>. Then, it's possible to export the desired branch as a .reg file, so later you can compare it with the same exported brunch from the current system.

Since the whole registry is a big fat thing, I compared the related areas only (as referred here: <a href="http://support.microsoft.com/kb/300956">How to manually rebuild Performance Counter Library values</a>)

And actually, I didn't found anything outstanding there, the only delta between the two was the actual current counters' readings, and the "First"/"Last" counter numbers for various instances, while both of differences makes sense and doesn't clearly indicate any problem.

Anyways, the same MS KB article refers "lodctr /r" as a safe fix, without any potential drawbacks. So I think we can go with this solution for now.
Besides, all the registry research became too time-consuming, and we already have a decent solution here.

BenYeeHua

Ok, thank for the information, I guess it can be other hidden place that it also restored. :)

geloxo

Latest update (v6.7.0.28) solved the problem with CPU per core graph in my case. Thanks a lot for the support!

BenYeeHua

Quote from: geloxo on December 13, 2013, 12:17:55 PM
Latest update (v6.7.0.28) solved the problem with CPU per core graph in my case. Thanks a lot for the support!
Thank for letting us know about that, it is because smartbit found which is the cause, and the solution. :)

You can choose to not answer this, but I just want to know, which software did you think it might causing this issues?
(It can be some software that optimizing or collecting data about performance)

I just want to know which software causing it, so that I/we can report to that dev of software about this issues.
If that dev can't be contact, then at least I/we can avoid it. :)

geloxo

Hi BenYeeHua, sure no problem.

Honestly I don´t know what SW could be. I can tell you that today I updated to the latest lasso and prior to it Win7 autoupdated NetFramework 4.5.1, Defender, Internet explorer 11 plus other security KBs which I don´t know what they are. Last week I updated also Samsung Magician SW to v4.3 (a SSD toolbox included with a secondary disk I have) but anyway lasso was still not showing the graph after that update, and it worked ok with the old Samsung SW as well till the problem occured so I don´t think that Samsung SW was the reason. I don´t use any other SW for performance except HW64 (and MSI afterburner), as I said in the former posts. They are not updated since that moment and I don´t use them.

Sorry, I can´t help so much in this case..

BenYeeHua

Never mind, at least we has a solution, even we don't found who causing it. :)