News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

a problem in Process Lasso 6.7.0.6 x64

Started by Saad, November 19, 2013, 03:00:09 AM

Previous topic - Next topic

Saad

Hi,
since i updated process lasso to 6.7.0.6 , process lasso add new icon to notification bar for every program launch (Firefox or any other programs) in windows. but when i take mouse over icons, all of them will be hidden except one. please fix. thanks.

i'm using win8 x64 .

BenYeeHua

Strange...
I don't facing this issues, and I am also using Windows 8 x64.

It look more like each time a new program started, the tray icon has recreate, or more likely crashed and restart itself.

Did you using Anti-virus or something that will hijack the Process?

And, did you try restart your computer?

Saad

my PC has restarted several times. i use Kaspersky Internet Security 2014.

BenYeeHua

What's showing in the log?
Did it showing that it is being crashed, and restarted the engine?

edkiefer

Bitsum QA Engineer

BenYeeHua

Quote from: edkiefer on November 19, 2013, 09:03:33 AM
maybe take a pic of issue .
I think you might know what's the issue, which is if you are using the player or game that using DirectShow, when the decoder played each time the video, it will left a icon at the tray icon area.

When you move the mouse over the tray icon, it will gone until the last one that is running.

A old windows bug that I don't how it can be happen.

edkiefer

Ok, your talking system notification icons area, in taskbar next to clock ?

I thought he was talking in PL which confussed me .

Any issue with tray icons, sometimes it needs a cleaning .
Bitsum QA Engineer

BenYeeHua

Yes, and most of the time this happen(the dead icon left) only when that software is crashed, so if the log are showing it is being started again, then it is a crash.

Saad





and log:
http://isaad.persiangig.com/pl6.7.0.6_log.CSV (http://isaad.persiangig.com/pl6.7.0.6_log.CSV)

BenYeeHua

So, did it also showing like this now?

Because from the log, I only saw this.
2013-11-19 07:47:43,MYPC,Saad,4304,ProcessLasso.exe,[ERROR: missing string],Parent taskeng.exe (4716), PATH: C:\Program Files\Process Lasso\processlasso.exe,"C:\Program Files\Process Lasso\processlasso.exe"
2013-11-19 07:47:43,MYPC,Saad,5776,processlasso.exe,[ERROR: missing string],Ran for 19 mins 7 secs. Average CPU use 0.32%.,
2013-11-19 07:47:48,MYPC,Saad,2344,dllhost.exe,[ERROR: missing string],Parent PID 788, PATH: C:\Windows\SysWOW64\DllHost.exe,C:\Windows\SysWOW64\DllHost.exe /Processid:{06622D85-6856-4460-8DE1-A81921B41C4B}
2013-11-19 07:47:53,MYPC,Saad,2344,dllhost.exe,[ERROR: missing string],Ran for 5 secs. Average CPU use 0.15%.,
2013-11-19 07:47:54,MYPC,Saad,6032,dccw.exe,[ERROR: missing string],Parent explorer.exe (5096), PATH: C:\Windows\system32\dccw.exe,"C:\Windows\system32\dccw.exe"
2013-11-19 07:47:55,MYPC,Saad,1400,ProcessLasso.exe,[ERROR: missing string],Parent taskeng.exe (4716), PATH: C:\Program Files\Process Lasso\processlasso.exe,"C:\Program Files\Process Lasso\processlasso.exe"
2013-11-19 07:47:55,MYPC,Saad,4304,processlasso.exe,[ERROR: missing string],Ran for 12 secs. Average CPU use 1.44%.,

So it has been crashed, but the first one has been running for 19 mins 7 secs.

Try follow this, and the dev will check for it, if you got the minidump for it.  :)

QuoteAs it is crashed, you can find the minidump at %LOCALAPPDATA%\CrashDumps.
Just upload the minidump by using attach, if you don't wanna let other people get it, just email to Official Support, you can find his email here.
https://bitsum.com/forum/index.php?action=profile;u=1

PS:The minidump name should be processlasso.exe.xxxx.dmp

Saad

sorry, my report has a mistake. it not crash for all programs running, but for must.

"CrashDumps" folder there is not in %LOCALAPPDATA%

for email view shows this error: "You are not allowed to access this section".

edkiefer

I see all the missing string errors , could it be a language issue between PL and your location ?

For test is it easy to change to say US ,English just to see if stop crashing , just a idea .
Bitsum QA Engineer

BenYeeHua

Quote from: Saad on November 20, 2013, 04:53:52 AM
sorry, my report has a mistake. it not crash for all programs running, but for must.

"CrashDumps" folder there is not in %LOCALAPPDATA%

for email view shows this error: "You are not allowed to access this section".
En...
It must be the same like another person Smartbit that also facing crash issues, disabled by other software or moved to other folder, as you can't has 0 program crashed in past.

QuoteCheck the registry value, it should be somewhere, or being disabled by some software that wanna save space.
http://msdn.microsoft.com/en-us/library/windows/desktop/bb787181%28v=vs.85%29.aspx (http://msdn.microsoft.com/en-us/library/windows/desktop/bb787181%28v=vs.85%29.aspx)
Just like this, check the registry value, it can be some software want to get their minidump.
I has facing 1 times that the "Soluto" set the minidump folder to their software folder. :)

Quote from: edkiefer on November 20, 2013, 07:53:11 AM
I see all the missing string errors , could it be a language issue between PL and your location ?

For test is it easy to change to say US ,English just to see if stop crashing , just a idea .
Nope, I just check myself, it is the log viewer bug. ;D
But yes, I will wait for your confirm, if this "[ERROR: missing string]" also showing on your side, then I or You just open a new bugtrack thread for this bug.

edkiefer

no, no error listing in my log, looking at log viewer now .

what column is the error in ?

PS: I start PL manually if that makes any difference .
Bitsum QA Engineer

BenYeeHua

Quote from: edkiefer on November 20, 2013, 09:32:13 AM
no, no error listing in my log, looking at log viewer now .

what column is the error in ?

PS: I start PL manually if that makes any difference .
That error will come out after you just click Export log to CSV, save the CSV and open the CSV. ;)

For which column is that error, I don't know.

edkiefer

Oh, I thought you meant while viewing the log from logviewer .

Ok, I got to file>log to cvs , save to document folder.
Open cvs log with notepad , all seem ok here .

Edit; Wait a second , something wrong here , the log contains not right , up to date log info . (over 3 months old ) .
Edit2: If I use option from PL GUI file menu no errors in log.
If I use export to cvs from logviewer file>menu I do get missing string errors

Now just have to figure why my log doesn't display right log info in the cvs file .
Edit3: Ok cleared log fixed it but again no error of missing string from PL GUI file>export to cvs .
Error shows up in logveiwer >file>export to cvs .
Bitsum QA Engineer

BenYeeHua

QuoteIf I use export to cvs from logviewer file>menu I do get missing string errors
Yup, I means this.

So, if we are using LogViewer and export to CVS, then we get the missing string errors, confirm? :)

edkiefer

Quote from: BenYeeHua on November 20, 2013, 12:30:12 PM
Yup, I means this.

So, if we are using LogViewer and export to CVS, then we get the missing string errors, confirm? :)
Yes.
Bitsum QA Engineer

Jeremy Collake

I will report on this soon, I'm going to deal with several outstanding issues in the coming days, with great efficiency (or so I hope ;p).

The 'missing string' errors you see in CSV exports of the log is a localization bug. I will deal with this too.

As for the OP original issue here, this would be caused by repeated crashes/restarts of the GUI. It may be related to a separate report of occaisional GUI crashes.
Software Engineer. Bitsum LLC.

BenYeeHua

Quote from: Official Support on November 21, 2013, 12:27:27 PM
I will report on this soon, I'm going to deal with several outstanding issues in the coming days, with great efficiency (or so I hope ;p).
Yup, and you has also a zombie process waiting for you here, which is affecting windows 8.1 user, and the newest version likely causing the zombie process don't go away even PL has been closed.

There are a sample code there you can see, it might be easy to fix this first. :)
https://bitsum.com/forum/index.php/topic,3594.0.html

QuoteThe 'missing string' errors you see in CSV exports of the log is a localization bug. I will deal with this too.
Yup, I has open a new topic for that, and surprised that it will also affecting English...

QuoteAs for the OP original issue here, this would be caused by repeated crashes/restarts of the GUI. It may be related to a separate report of occaisional GUI crashes.
Ya, and OP don't find the minidump to confirm there are the same yet, too bad there are some software like to disable or changed the minidump save folder...

smartbit

Quote from: BenYeeHua on November 20, 2013, 08:43:51 AM
En...
It must be the same like another person Smartbit that also facing crash issues, disabled by other software or moved to other folder, as you can't has 0 program crashed in past.

Adding this key enabled dump creation for me:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps]
"DumpFolder"=%LOCALAPPDATA%\CrashDumps


On the issue:
It does resembles the crashes I'm experiencing <a href="https://bitsum.com/forum/index.php/topic,3596.0.html">here</a>.
Also it seems like in the Saad's case, the UI process restarts himself after a possible crash, creating several icons in the sys. tray (one alive, any many ghosts).
I have this effect only if i continue to launch PL again manually after a crush, and hence, getting a new, "alive" icon.

Edit 1: Try look at the windows log as well: Open "Event Viewer > Windows Logs > Application", and look for the time that the issue happens (as suggested by Official Support <a href="https://bitsum.com/forum/index.php/topic,3596.msg13843.html#msg13843)">in my case</a>).

Edit 2:
Quote from: Saad on November 20, 2013, 04:53:52 AM
for email view shows this error: "You are not allowed to access this section"
The mail is support@bitsum.com (it's an official support, as can be found <a href="https://bitsum.com/support/">here</a>)

BenYeeHua

Thank for the minidump information, I wonder why windows will not create the dump for you, but it create the dump for me even without the folder added to the registry key.

smartbit

Quote from: BenYeeHua on November 22, 2013, 05:13:57 AM
Thank for the minidump information, I wonder why windows will not create the dump for you, but it create the dump for me even without the folder added to the registry key.

(a bit off the topic), but: I checked my other PC with clean stock Windows 7 install, I've done by myself (unlike the laptop with preloaded / tuned windows) and:
- No registry key
- No CrushDumps ever created there

Seems like this is the default windows config. to me... Maybe you ever used some SW that enabled it. Or not. I'm just guessing, anyways...  :P

BenYeeHua

Ya, but I think I know something.
The doc is writing as
QuoteThis feature is not enabled by default. Enabling the feature requires administrator privileges. To enable and configure the feature, use the following registry values under the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps key.
So it can be:
1.I disabled the UAC, so normally software that running with Admin right will be created a minidump
2.Windows 8 enabled it as default, and they don't update the doc...

And there are nothing inside the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps , so I guess it is Windows 8 changed the default. :)

Jeremy Collake

A different user had reported a GUI crash, that, after diagnosis, ended up being caused by a faulty third-party shell extension that was crashing while drawing overlays over the process icons. It was 'sugarsync' in that case. I'd recommend you disable 'View / Show process icons' as a diagnostic step.

If a minidump has been (or is) collected, please email it to support@bitsum.com with 'minidump' somewhere in the subject and I'll be able to more immediately tell you what's going on.
Software Engineer. Bitsum LLC.