Realtime setting not sticking

Started by Cartoonman, December 21, 2013, 04:43:48 PM

Previous topic - Next topic


I have a setup where there's 5 processes; four of them are set as idle, each taking up a fourth of the total cpu cycle, and the fifth using marginally any cpu, but this particular process I need to set as Realtime to have it utilize what it's supposed to do fully. The problem is this application 'restarts' every 15 minutes or so, and when it does, Process Lasso occasionally doesn't seem to catch the process in time to set the priority and stuff. When this happens the process usually is stuck with a 'high' priority, which increases it's runtime by up to 2 hours before it's next cycle, when process lasso (hopefully) picks back up and resets the default priorities.

I've tried forced mode, decreasing the governour refresh rate to 100ms (and increasing it to 5 seconds), and this still seems to be an issue. I had tried Prio before for this but that never set the priority to realtime, it only settled for high. Permissions make this problematic.

This is running on a Windows 7 x64 Ultimate. The application in question is a x86 app.

Jeremy Collake

Please update to v6.7.0.34. A bug in versions released the last couple months would cause processes to be 'missed' sometimes.
Software Engineer. Bitsum LLC.


Thanks, my setup had on it so I updated it to .34. I'll see how it goes.