News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

[Resolved]: "*ESET*, *WindowBlinds* & *Start8* Are Being Launched, NON-STOP"

Started by mustib, June 06, 2014, 04:42:09 AM

Previous topic - Next topic

mustib

Had always been using the following 3 processes under the Keep running (restart if terminated) function of Process Lasso:--

ekrn.exe (affected)
    "C:\Program Files\ESET\ESET NOD32 Antivirus\x86\ekrn.exe"
WBSrv.exe (affected)
    "C:\Program Files (x86)\Stardock\WindowBlinds\WBSrv.exe"
Nexus.exe (not affected)
    "C:\Program Files (x86)\Winstep\Nexus.exe"

Until recently, Process Lasso was running great - the last release that worked fine for me, was the beta v6.7.0.59. It all started with v6.7.0.63  when I began seeing frequent spikes and had to uninstall Process Lasso from my systems:--



Apart from the continuous spikes another reason for uninstalling Process Lasso from both my systems was the following flurry of incessant activity (@ 3 events per second):--



ekrn.exe and WBSrv.exe are being launched continuously despite the fact that that they were already running. The issue is present in the latest stable v6.7.0.64, too - however, Nexus.exe continues to remain unaffected.

I feel that this sudden issue which has just manifested itself might somehow be connected to the following new point of your changelog:--
  • Refactored the 'Keep Running' (auto-restart process) feature. You can now keep multiple instances of the same process running with differing command lines.

System Specifications:--
  • Processor Sandy Bridge, QuadCore i7
  • Windows 8.1 Update (x64-bit, Pro)
  • Windows 7 Ultimate (x64-bit)
  • RAM 16 GB

Edit:--
For those who won't like to read the complete story, v6.8.0.3 fixes this issue.  ;D

BenYeeHua

As this is a bug, I will moving it to bugzilla.

And I guess, the processes are not terminated itself/still running, but somehow Process Lasso think they are terminated, and rerun it again and again, right? :)

mustib

Ah yes, BenYeeHua!!!  :)

Thanks for your response.

Guess Process Lasso does seem to think that those processes were terminated and is launching them again and again, repeatedly - thanks again.

BenYeeHua

And ya, just want to make sure. :)

Did ESET block Process Lasso Engine(Process Governor) access to these processes?
If Process Lasso don't has access to the processes, it might think they are terminated.

mustib

Despite the fact that ESET and Process Lasso - both, got along very well (right from the installation stage,) I had made exclusions in ESET for the complete Process Lasso directory, just for added insurance.

Process Lasso had no issues whatsoever in handling the ESET processes. :)

BenYeeHua

Just want to make sure did ESET don't do anything to Process Lasso, check the ESET logs, sometimes anti-virus love to do the thing you has disabled/exclude, or it is just for scan.  ;)
http://kb.eset.com/esetkb/index?page=content&id=SOLN3217

mustib

Been using ESET - the standalone NOD32 EAV for a number of years (right from the early V2.)

The version referred to, on my OP is the latest v7.0.317.4 and logs were dutifully referred to before starting this topic - historically, NOD32 has always been honoring the exclusion list on both my systems. :)

BenYeeHua

Hmm, I guess I will need to see did any other user that also using Keep running (restart if terminated) function and check did it also broken on her side, while waiting the dev to check on it.

And ya, sorry for letting you to waiting so long, as the only dev is busy on the other thing now. :)

mustib

Just noticed a new release - so, I reinstalled the 6.8.0.1 beta to check out on the ESET & WindowBlinds issue. Unfortunately, the issue continues to exist but I can understand perfectly well - no problem. :)

Was just about to uninstall Process Lasso again, when it occurred to test whether the issue reported, was reflecting on any other process and I found one more:--

Start8Srv.exe (affected)
    "C:\Program Files (x86)\Stardock\Start8\Start8Srv.exe"

I feel this issue occurs when the PID of the process which is configured to Keep running (restart if terminated) does not remain constant:--




System Specifications:--
  • Processor Sandy Bridge, QuadCore i7
  • Windows 8.1 Update (x64-bit, Pro)
  • RAM 16 GB

BenYeeHua

That is normal, you should get a new PID for difference process, or your system is corrupted. ;)

mustib

Nope the PID does not change for Nexus.exe as mentioned on my OP (reproduced below):--

Quote from: mustib on June 06, 2014, 04:42:09 AMNexus.exe (not affected)
    "C:\Program Files (x86)\Winstep\Nexus.exe"

edkiefer

That's because it hasn't refreshed/restarted .
Everytime a app starts a new number is given .

Take Calc.exe, open and close it many times, each will have unique ID # .
Bitsum QA Engineer

mustib

But then, neither were ESET nor WindowBlinds or even Start8 been restarted.

BenYeeHua

Quote from: mustib on June 08, 2014, 10:29:54 AM
But then, neither were ESET nor WindowBlinds or even Start8 been restarted.
Interesting, it may something more about this bug.

Can you use other software like Process Explorer or Process Monitor to check for it?
For Process Explorer, it will showing the new process by using green highlight, and end process by using red highlight.
PID is also 1 of the ways to check did they are the same process or not. :)

Jeremy Collake

Thanks for the heads up.

First, Lasso sure looks nice with WindowBlinds ;)

Yes, this bug is caused by the recent Keep Running refactoring.

The focal point of the issue is surely in the command line handling. It is trying to re-launch these processes, but they already have instances running (/w different command lines), so they immediately close themselves.

I am considering the adjustment that needs made to deal with this issue. Please hold and I'll get it addressed, then ask for a confirmation of the fix.

Software Engineer. Bitsum LLC.

edkiefer

Quote from: support on June 08, 2014, 11:22:27 AM
Thanks for the heads up.

First, Lasso sure looks nice with WindowBlinds ;)

Yes, this bug is caused by the recent Keep Running refactoring.

The focal point of the issue is surely in the command line handling. It is trying to re-launch these processes, but they already have instances running (/w different command lines), so they immediately close themselves.

I am considering the adjustment that needs made to deal with this issue. Please hold and I'll get it addressed, then ask for a confirmation of the fix.
Ah, so it because there using switch with exe that is throwing it off .
Bitsum QA Engineer

Jeremy Collake

In the interim, here is a probable work around:

1. Clear all your Keep Running processes (see Options menu to open Keep Running dialog)
2. Add them back by right-click on their running instances and selecting 'Keep Running (restart if terminates)' from the context menu
3. This will add them to the list with their proper command lines. That will keep them from being perpetually restarted because the command lines you have in the Keep Running list doesn't match what they actually run with.

Software Engineer. Bitsum LLC.

Jeremy Collake

Quote from: edkiefer on June 08, 2014, 11:25:27 AM
Ah, so it because there using switch with exe that is throwing it off .

Yes, it now must matches Keep Running processes to their command lines as well -- so an instance doesn't 'count' as running unless it's command line matches what is in the Keep Running list.

So, Lasso doesn't see a full match running -- it sees the processes, but not ones with matching command lines. Thus, it launches, then these processes close themselves because they are self-limiting to one instance. Then it launches them again.

If the Keep Running list has the right command lines, then it should be fine. That's why I suggested adding them back by right-clicking on them in the process list. That will ensure they get the right command line.

As usual, a change to fix an edge case has caused problems with general use cases.
Software Engineer. Bitsum LLC.

Jeremy Collake

I am building v6.8.0.3 beta with an experimental change that may fix this. Please let me know.

It'll be up in about 30 minutes.
Software Engineer. Bitsum LLC.

mustib

@ support

Thanks for the constructive response - shall be ever willing to test a beta (or even alpha) for you. :)

LOL, we must charge Stardock for the advertisements that they have been receiving absolutely free of cost. :D

Have just noted your additional responses while typing this message (shall follow the suggestions and get back.)



@ BenYeeHua

Had also grabbed a screenshot of Process Explorer before having the opportunity to see the positive response from support - anyways, here goes (Process Explorer, at your service):--


edkiefer

Quote from: support on June 08, 2014, 11:25:31 AM
In the interim, here is a probable work around:

1. Clear all your Keep Running processes (see Options menu to open Keep Running dialog)
2. Add them back by right-click on their running instances and selecting 'Keep Running (restart if terminates)' from the context menu
3. This will add them to the list with their proper command lines. That will keep them from being perpetually restarted because the command lines you have in the Keep Running list doesn't match what they actually run with.
Tried this with MSI Afterburner which uses /s switch in launch line.
1) I set it w/o switch, just add path of exe
problem as OP mentions , keeps filling log and restarting AB .

note this was a problem cause even after this I remove the line from keep running process , it didn't clear. I had to manually edit the ini, remove line, save
then all works (as in able to remove keep running line)
Edit : just realized I was hitting the yes button on popup after you remove line from menu, this add it back, so my bad, it does remove it ok .
2) I then right click on MSI AB and pick keep running process which adds proper /s switch , all works as it should, no restarting issue .
Bitsum QA Engineer

mustib

@ support

I concur with edkiefer - findings based on the latest available v6.8.0.1.

Jeremy Collake

Yep guys, that is the exact fix I added - to match an empty KR command line with ANY command line. That is the core of the problem.

@Ed: Good to hear that adding KR processes via the context menu does work as intended, since again it then adds them with the appropriate command lines.

Build almost done.. probably 15 mins, then check for v6.8.0.3 beta.

I haven't tested it myself yet. Please report back and I promise you I'll get this resolved, if this doesn't do it (it should).

And thank you for reporting this problem!
Software Engineer. Bitsum LLC.

mustib

Quote from: support on June 08, 2014, 12:01:20 PM
Please report back and I promise you I'll get this resolved, if this doesn't do it (it should).

And thank you for reporting this problem!
w00ts!!!

Yes, the 6.8.0.3 fixed it for me, straight away - I am a happy Camper, now. :D

edkiefer

Quote from: support on June 08, 2014, 12:01:20 PM
Yep guys, that is the exact fix I added - to match an empty KR command line with ANY command line. That is the core of the problem.

@Ed: Good to hear that adding KR processes via the context menu does work as intended, since again it then adds them with the appropriate command lines.

Build almost done.. probably 15 mins, then check for v6.8.0.3 beta.

I haven't tested it myself yet. Please report back and I promise you I'll get this resolved, if this doesn't do it (it should).

And thank you for reporting this problem!
Works now with just paths , no switch needed  and no switch added to ini process line either but it works as should .

Ok, I never use this option but I notice if I add process and right clicking on process and adding keep alive I see the command line switch.
I don't know how code works on your fix but me, I would like to see the switch added if possible on just path mode if possible.

I say this just so its clear for those that look at command line column so it matches , not biggy at all as it works now either way .
Bitsum QA Engineer

BenYeeHua

Good to hear about it is fixed, I hope this issues did not affecting you too much. :)

Jeremy Collake

Thanks for the confirmation it works guys!

I'm doing code review and testing, then push a new final on out. I won't have time to revist things for a bit, so want to get this done.

@Ed: I'm not entirely clear yet on what you mention, but I will fiddle around and probably see the scenario you are talking about. Whether or not I address it this next release, dunno.
Software Engineer. Bitsum LLC.

Jeremy Collake

Ed, so you want an option to NOT include the command line switches when adding a new KR process from the context menu? I can't envision an easy way to accomplish that without unnecessary complication, so will defer.

The KR system, and many other features, do need more clearly explained and presented to the user for sure.
Software Engineer. Bitsum LLC.

edkiefer

Quote from: support on June 08, 2014, 09:42:54 PM
Ed, so you want an option to NOT include the command line switches when adding a new KR process from the context menu? I can't envision an easy way to accomplish that without unnecessary complication, so will defer.

The KR system, and many other features, do need more clearly explained and presented to the user for sure.
No , let me try an explain .
Lets add with right click method , in the command line of the keep process window, you see the switch there. this is good as it matches what GUI, command line column .
Now add same process with only path option in keep process running window, there no switch shown but it works, this is what i mean can it show the switch ?
I don't know if your fix added some kind of "if" process has switch run it with switch but it doesn't list it .

Hope that makes sense, its very minor thing .

Edit: here small example why i say this .

Say I have a app.exe that runs with /x and one day it starts acting up (either not restarting like it should or endless restarts ) . So I look around and see in command line column of PL GUI that it normally runs with switch /x .
So I go to check keep running process menu window and its listed with no switch (even though it works without having switch shown) . So I add switch but of course that is not issue and it must be something else .

Thats all just so it shows the switch like it would/does if you right clicked to add that app to keep running window , where it shows switch .
Bitsum QA Engineer

mustib

Quote from: BenYeeHua on June 08, 2014, 04:56:43 PM
Good to hear about it is fixed, I hope this issues did not affecting you too much. :)
All is well that ends well - was an inspiring experience. :)

Have updated to the 6.8.0.4 stable - working great, for me.

BenYeeHua

Quote from: mustib on June 09, 2014, 09:54:00 AM
All is well that ends well - was an inspiring experience. :)

Have updated to the 6.8.0.4 stable - working great, for me.
So you want more similar experience?
Just kidding. ;D

Jeremy Collake

Quote from: edkiefer on June 08, 2014, 10:42:21 PM
Lets add with right click method , in the command line of the keep process window, you see the switch there. this is good as it matches what GUI, command line column .
Now add same process with only path option in keep process running window, there no switch shown but it works, this is what i mean can it show the switch ?

Ah, I see. Yea, that's possible to add, as long as the process is running, or was recently run, so that the switch can be retrieved to show the user in the Keep Running config dialog.

Glad it's working guys!
Software Engineer. Bitsum LLC.

edkiefer

Quote from: support on June 10, 2014, 04:17:35 AM
Ah, I see. Yea, that's possible to add, as long as the process is running, or was recently run, so that the switch can be retrieved to show the user in the Keep Running config dialog.

Glad it's working guys!
Yes, That would be good .
Bitsum QA Engineer