UAC elevation prompt at login not solved by reinstallation etc.

Started by mjdl, February 07, 2015, 03:12:48 PM

Previous topic - Next topic


Until Jan. 2014 I was running PL on Windows 7 x64 without any problems in the standard installation configuration. From Jan. 2014 to Jan. 2015 I ran a new installation of Windows 8/8.1 Pro on the same machine. PL again ran in its standard configuration w/o problems for a standard limited user.

I've had to switch back to Windows 7, since the laptop lost several nicely developed custom software/hardware OEM features that were not carried on to the Windows 8 platform; and even if virtually all the hardware was supported by Windows 8 in-box drivers, some of these were just not as stable as the Windows 7 OEM drivers, which have never really crashed at all.

Anyway, on this fresh installation of Windows 7 SP1 x64 w/all current patches applied, PL always puts up a UAC elevation prompt the first time the unprivileged user un-minimizes the GUI from the task icon. No amount of reinstallations w/different start-up options will solve this: e.g., even setting it to manage just the user's tasks, rather than ALL tasks the user has access to, still entails UAC elevation in order to display the GUI. Or choosing a central location for the ini and log files, and setting permissions for full access for all users on that location still does not banish the UAC prompt.

What information/files do I need to PM/email privately in order to diagnose this situation? I do have Sysinternals ProcMon on my system, but I'll need your instructions to configure it (the monitoring files are huge otherwise).

UPDATE: Removing the "Run at highest privileges" from each of the PL tasks seems to solve the UAC-on-unminimize problem. When I attempted to then remove the tick mark from "Manage all user process" from the Main menu of the GUI, UAC elevation was required, but the GUI restarted w/elevated privileges but no longer visible on the desktop but still in the task list. When I logged out/in again, the GUI behaved normally, and the "Manage all processes" was unticked in both menu locations, as required.

But this whole UAC elevation issue is very confusing: if the PL login tasks are run in an unprivileged "Users" group context, but ask for highest privileges, isn't that obligatorily going to raise a UAC credentials dialog anyway, so that the process can acquire the necessary administrative token to mange all processes which may be visible to it, but are running in another user's context?

Jeremy Collake

I think (skimming, sorry) the problem is that you've pinned ProcessLasso.exe to the Taskbar or Start Menu instead of 'ProcessLassoLauncher.exe' . The latter won't ask for elevation if Lasso is already running, hence it's purpose.
Software Engineer. Bitsum LLC.