Author Topic: I got this program - over the years - from Giveawayoftheday.com  (Read 4628 times)

Offline Radiodoc

  • New
  • *
  • Posts: 4
 :(     

Imagine how perplexed I was when my screen kept going "blank/black" every 20 minutes or so when I had ProcessLasso running.

The point was - It took me ages to discover that it was THIS program which was causing me to lose what little hair I still had!

Yes, all right, once discovered - I could enter the set-up and set the screen to never switch off -- BUT that was only valid until I switched off for the night, and was NOT a "sticky" fix. i.e. I HAD to keep repeating this "Keep PC awake" command with every start-up.... which is - to me anyway - annoying >:( ....

I wish I could demand the control to stay "stuck" at "on all the time" until I MIGHT need it off!

In reality - I've only used P.L. to be able to monitor the activity of my Quad CPU's when I'm hammering them - so, I suppose I could quit using Pro'Lasso and hopefully, my screen would - then - not keep switching to "blank".

I can't recall ever having such problems with earlier versions.

Any "fixes" to cure the annoyance?

« Last Edit: March 13, 2015, 11:53:41 AM by BenYeeHua »

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #1 on: March 13, 2015, 08:41:27 AM »
Which version of process lasso are you using.
Chris

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1789
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #2 on: March 13, 2015, 08:51:36 AM »
what options in PL were you using before having this issue .
If you were running like power saving ,it is just pointing to a power profile in windows .
So first thing would be to check power options in control panel , how is display and sleep are setup .
Bitsum QA Engineer

Offline BenYeeHua

  • Member#
  • *****
  • Posts: 2232
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #3 on: March 13, 2015, 11:55:50 AM »
Just saying, making the text hard to read don't helps you to fix the issues. :)
Can it be power save functions? Because the monitor turn off are changed by Power Plans.

You can also provide the Process Lasso's log to let us see what's going on. ;)

Offline Radiodoc

  • New
  • *
  • Posts: 4
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #4 on: March 13, 2015, 11:36:28 PM »
It is V7.8.2 x64

Windows 7 Ult control panel is set so that it NEVER Turns off the display *&* NEVER puts the computer to sleep.

I had hoped that shutting of Process Lasso would resolve this problem - but it didn't - I feel that it is a rather drastic measure to totally remove the entire program and I can NOT find it in MSCONFIG to immobilise it THERE!

As for P.L's Log - Seems impossible to capture - for one thing it takes more than one screen - and the other --> Cut & Paste does not work in the viewer program.

I'd be prepared to tolerate the immediate annoyance of screen blanking after about ~20 minutes ---> If only I could "lock" this program PERMANENTLY to NEVER blank the screen!

Does shutting down P.L. *Completely* remove ALL active elements of this program?  It certainly causes the screen to blank out after ~20 mins regardless of the Control Panel settings [noted above].

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #5 on: March 13, 2015, 11:44:17 PM »
You have several power profiles in windows power options which are you using. You can set the monitor and pc to sleeps for each of those. Make sure you are using the one you told not to go to sleep.
It would look like this for each profile. Process Lasso just switch's between these if you tell it to.

Chris

Offline Radiodoc

  • New
  • *
  • Posts: 4
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #6 on: March 14, 2015, 12:13:35 AM »
 >:( As I explained previously "Power Options" are - and always have been set to never switch off display & never "lay down to sleep" <Grin>.

I am bemused WHY the darned screen display - but NOT the fluorescent tubes behind it - blanks off after ~20/25 minutes BUT this can be stopped by the "always on" command in P.L.

If this was a PERMANENT sticky command, I'd settle for that - just for a "quiet life" but it is annoying that with every re-start I am FORCED to select the "always on" command in P.L. <Grrrh> since I can find no way to "stickify" this selection.

Why doesn't P.L appear anywhere in "MSCONFIG" -yet auto-starts up?  i.e. I can NOT stop it loading - except by [possibly] deleting the entire program?  I do not recall either versions inflicting this annoyance on me. 

I'd delete this version and go back to an earlier version if I could be SURE that some parts of 7.8.2 weren't left behind to sabotage me.

As it is, I'm only interested in the % values of my 4 CPU cores when I hammer them - that's the only reason I run it for - not the incessant requirement to click on "always on = never sleep" each time I restart the 'puter!

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #7 on: March 14, 2015, 12:20:22 AM »
You can stop it from auto starting from the task scheduler. Click start button and type task scheduler in "Search programs and files". Once it comes up click "Task scheduler library" you will see two entries for Process Lasso, right click on them and disable.
Chris

Offline BenYeeHua

  • Member#
  • *****
  • Posts: 2232
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #8 on: March 14, 2015, 07:27:53 AM »
It is run by Task Scheduler, you can also saw many apps like Google Updater on there too, along with other Microsoft's software that also hidden in the folder. ;)
The easy way to config how's PL auto start is just run "Options - General Settings - Reconfigure the way Process Lasso starts ..."

For the Sleep and monitor auto turnoff, you can use powercfg /energy to check the "current" settings/info.
You can also check the Event Viewer, it should record who is changing the sleep settings.

Last time I found my CPU frequency is locked to 100%, but the Event Viewer is telling me the TouchPad software(yup, bad coding by the OEM), so you should also can find who do that on there. ;)

So far I has put the computer overnight, and it don't sleep itself when PL is running, but it can be a bug in PL that only happen with your Computer. :)

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1789
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #9 on: March 14, 2015, 07:43:11 AM »
It is run by Task Scheduler, you can also saw many apps like Google Updater on there too, along with other Microsoft's software that also hidden in the folder. ;)
The easy way to config how's PL auto start is just run "Options - General Settings - Reconfigure the way Process Lasso starts ..."

For the Sleep and monitor auto turnoff, you can use powercfg /energy to check the "current" settings/info.
You can also check the Event Viewer, it should record who is changing the sleep settings.

Last time I found my CPU frequency is locked to 100%, but the Event Viewer is telling me the TouchPad software(yup, bad coding by the OEM), so you should also can find who do that on there. ;)

So far I has put the computer overnight, and it don't sleep itself when PL is running, but it can be a bug in PL that only happen with your Computer. :)
But if all his power profiles have sleep and no disable display shutdown time, then it shouldn't be happening .

PL doesn't directly do anything with sleep, it just changes which profile you use .

Also if processgovernor exe is not running PL doesn't do anything .
Bitsum QA Engineer

Offline BenYeeHua

  • Member#
  • *****
  • Posts: 2232
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #10 on: March 14, 2015, 09:18:06 AM »
So ya, many possibility in this case, but it can be just
1.PL issues that somehow the code that control sleep function is having issues, and enabled sleep for some computer
2.Windows issues that switch on the sleep but not showing it on the control panel
3.other programs doing that when PL running, conflict I think...

So I guess the best ways to find out it just read the Event Viewer, it should be recorded as Power event. :)

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1789
  • Gender: Male
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #11 on: March 14, 2015, 09:37:22 AM »
Yes, event viewer should show what is doing it .

PL logs can help as far as PL goes , he can export to csv format and copy paste from there too .
Bitsum QA Engineer

Offline Radiodoc

  • New
  • *
  • Posts: 4
Re: I got this program - over the years - from Giveawayoftheday.com
« Reply #12 on: March 18, 2015, 02:38:14 AM »
As I have intimated earlier; BOTH "buttons" in the Control Panel are set so that the external LCD screen is never switched off.

The "shut-down" the screen was a problem I endured for months PRIOR to having to totally re-install Win 7 Ult.  The 'puter went mad after I'd replaced a {foolishly} suspected dieing CMOS battery.

Once I had reinstalled Win 7 and some of my essential program, the mysterious misery restarted in switching off the screen display after around 20 minutes  - IF I wasn't doing anything on the keyboard.

I can get away (somewhat) from this problem by firing up P.L. and selecting "never switch off" - but that isn't a "Sticky" command and each and every time I cold boot, I have to do this all over again.

It was suggested (earlier) that I could "attack" the reg to stop P.L automatically starting up on switch-on -- but whilst that "reg-tweak" DID stop the automatic load & run of P.L. - Now there is no icon on my screen, and I have to go back to the "all programs" button and run it from there.... which seems to be a worse condition than the original one where - at least - it started automatically - but forced me to select "keep computer awake indefinitely.

I'm NOT laying any "blame" on P.L. 'cos I know that this wretched blanking of my screen has only - relatively - recently occurred, BUT I do wish I could see a way to permanently "lock" so that I don't have to go thro the P.L menu each time after starting up P.L. i.e. I have no objection to using P.L. It may do me some good - but the lack of a "sticky" is rather frustrating. I wish that a fix could be inserted !

My grateful thanks to those who responded to my enquiries!