News:

NOTICE: Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

IdleSaver and Windows 10

Started by F3Speech, August 13, 2015, 06:38:54 AM

Previous topic - Next topic

F3Speech

With Windows 8.1 IdleSaver just worked (free mode). After upgrading to Windows 10 it appears my computer is never idle now, even though it looks like its doing very very little from the stats presented to me via ProcessLasso. Can anyone help me resolve this issue - its a massive feature I'd hate to be missing out on.

I'm currently running the latest build in pro trial mode.

Thanks.

edkiefer

Hi

I think we need more info , first whats your System specs (CPU/MB platform ).
When you say its not idling right, do you mean CPU clock rate/voltage ?

Do you have it set were it switches to power saver power profile , is it switching ok to it ?
Bitsum QA Engineer

F3Speech

Thanks for the reply:

Processor: Intel Core i7-4790K 4.00GHz
Motherboard: Gigabyte Z97X-Gaming 5 Z97
Graphics: Gigabyte NVIDA GTX 970 G1 Windforce
Memory: Corsair Vengence Pro 8GB
Storage: 2 x Samsung EVO 840 SSD Drives

AV: BitDefender (have tried with and without this enabled)

Not its not idling 'right' its just not triggering the IdleSaver process even when its idle with as much unloaded from memory as I can get to. I have it enabled and set to change to 'Power Saving' after 5 seconds (for testing), enabled logging the change, it never changes to the 'Power Saving' power profile.

I've read that disabling IP6 and some wake on lan settings might help but Ive disabled those with no effect.

edkiefer

ok, can you check one more thing , lets get baseline, so set default power profile to balanced , then after your set time you don't see it change in log to power saver .

Can you also go to control panel>power config and see if it is power saver profile or still balanced .
Another thing to check, whatever power profile your in , try setting the display turn off time real low and see if it ever turns display off properly .

PS: there a shortcut to power plans in PL GUI under external tools .

This sounds like a windows OS issue , were it never goes to idle cause it still doing something or think that .

Just to make sure I tested power saver on the latest beta and it is working right, log shows changes properly , though I am on Win7 PRO 64bit.
Bitsum QA Engineer

F3Speech

Whatever setting I choose they don't move.

Tried setting the screen to go off after 1min on the active profile and this didn't happen either.
As you say more like a Win10 problem than PL

I'll post back if I find a fix, cheers.

Jeremy Collake

Tests show IdleSaver performing fine in Windows 10 in two test-beds I have going. And I'd tested before.

Plus, Win10 systems *do* properly go idle and the screen turns off, etc..

So, yes something odd going on in the OS or third-party software other than Process Lasso (unless you are using 'Keep Awake' I guess ;p).

Now, keep in mind there may be cases where Windows 10 prevents the PC from sleeping because it's running a task in the background that it wants to finish.

Check the Task Scheduler to see if there are any running tasks that have been configured to either wake the PC to run, or prevent sleep until they finish.
Software Engineer. Bitsum LLC.

F3Speech

I'm making little to no progress with this  :(
Even when I set IdleSaver to 1 second intervals it never changes.

Is there a tool or something that can tell me whats permanently keeping my PC awake?

My CPU bounces about 0-2% when Idle with background services etc is that a problem?
PL says there are no active processes, nothing can appear in the log for minutes and still the PC wont sleep or switch the screen off.

The only thing I can find re Win10 is a sleep bug that was patched last year.

Any help would be fantastic...

Jeremy Collake

Yea, IdleSaver in Windows 10 definitely works for me, and those who have tested it on our end (several testers).

About a month ago, we did see a similar report about Windows 10, which again was a 'whole system' problem.

So, you are at least not alone, but it's not a bug in Process Lasso. Something is forcing the PC to remain awake.

Did you check the Task Scheduler to see what tasks it shows as Running in the Status column?
Software Engineer. Bitsum LLC.

edkiefer

F3Speech
Just to make sure, could you reset bios defaults or go into CPU power management area of bios and double check all these options are on (EIST, C1E, C3, C6 and any other C option ).
Bitsum QA Engineer

F3Speech

http://www.tenforums.com/general-discussion/11232-no-screensaver-after-10-update-6.html#post331876

Found the above post with a lot of people describing the same issue - one guy describes disabling his X52. I have x52 flight stick too - I disabled it and all working!
PL now correctly changes my power management after 1 second (guess i'll have to increase this now lol)

Thanks to everyone for your help.

edkiefer

great, it was a simple thing .
Bitsum QA Engineer

Jeremy Collake

Excellent that you found the solution, and thank you for coming back to tell us what it was --- some people don't.

Now if we hear of this issue again we will have something to ask users about.
Software Engineer. Bitsum LLC.

edkiefer

#12
There are power management setting in device manager for USB hubs "allow the computer to turn off this device to save power" .
Might help if you want to leave it plugged in , but i generally disable these type of options .

Edit: I am assuming Win10 still has these options as I haven't moved to Win10 yet.
Bitsum QA Engineer

BenYeeHua

#13
Quote from: edkiefer on August 15, 2015, 08:54:51 AM
There are power management setting in device manager for USB hubs "allow the computer to turn off this device to save power" .
Might help if you want to leave it pulled in , but i generally disable these type of options .

Edit: I am assuming Win10 still has these options as I haven't moved to Win10 yet.
Yes, but I think it is useless, it is up to the driver support it or not... :P

edkiefer

Quote from: BenYeeHua on August 15, 2015, 09:31:32 AM
Yes, but I think it is useless, it is up to the driver support it or not... :P
Very well could be ,was just something to try .
Bitsum QA Engineer

BenYeeHua

Quote from: edkiefer on August 15, 2015, 11:03:14 AM
Very well could be ,was just something to try .
If it is a driver but not the software that causing it, then just create a shortcut to disable/enable the device should works. ;)