News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

Visual Studio Lag

Started by lmstearn, September 20, 2015, 01:15:49 AM

Previous topic - Next topic

lmstearn

Hi there,
6 core AMD fx 6200. NVIDIA, GTX 650,  1 TB Seagate ST1000DM1003 SATA Drive, 8 Gb Ram.

Pretty average specs, but hoped that VS would be more responsive when switching to it.
Just uninstalled VS2010 Pro where there was a lag with one project. It uses Git, wxwidgets and Boost. Boost is particularly heavy on the filesystem as it contains 75,000 files!

Upgraded to VS2015 RTM -it's still laggy when switching to it, especially with the large project, although pretty good once the app is in focus. The lag might be just a hardware limitation. Upped the settings for it in Process Lasso. Just curious as to the deal with Memory Priority. Would "Normal" be the highest setting?
Edit: VS relies on H/W acceleration so created a GPU 3D profile in NVIDIA CP for maximum performance,
Any suggestions on better performance?
Thanks. :)

edkiefer

Hi , I/O usage is always a problem and setting higher or lower priority doesn't help to much , you could try setting higher but having to many other processes at higher than default is not recommended .
As it normally works better to lower all other processes (this is what Probalance does ) . Leaving the focused process with less interference .

You didn't mention OS, I think later versions have better I/O handling , also I see you have 8gig , is that enough free once VC is loaded .

I haven't used VC in log time, maybe there a config file lets you set various things, like max memory or GPU HW , I don't know, but something to look at .
Bitsum QA Engineer

BenYeeHua

Well, Windows 8+ has better performance support for AMD bulldozer architecture, so upgrade OS should helps.(if the bound is also on CPU)
And disabling core parking should helps too.
https://bitsum.com/parkcontrol/

The Hard Disk(or I/O usage) should be the main issues, switching to SSD should helps, Jeremy(Bitsum Dev) can answer you better than us, so I guess it is better that just wait for him to come. :)


lmstearn

Thanks  edkiefer & Ben,
Didn't mention in the OP- yes it's Win 8.1. Another possibility is a malfunctioning GPU, Nvidia thinks it's a faulty capacitor- but for that one capacitor the card appears to be performing to specs. (It's 2015 and they still have not bundled any H/W testing or benchmarking S/W with their products).
Suspect diskclog as the main culprit here.
At the Visual Studio thread they have provided a good few solutions, so have plenty to do in the meantime. :)

BenYeeHua

Good to hear that you has found some guide to follow and try, and ya, Nvidia did at least provided Debug Mode which lower the factory overclocked card back to reference clock, so you know did it is a fault overclock by factory or not. ;)

QuoteA new "Debug" mode introduced in this driver will be useful for users with factory overclocked graphics cards to troubleshoot issues that are caused by overclocking. By selecting this mode, the driver will restore the clock speeds of your graphics cards to NVIDIA reference clock speeds. Please note at this time this setting is only available in English. Support for Debug mode in other languages coming in R358 driver branch.
https://forums.geforce.com/default/topic/872992/geforce-drivers/official-windows-8-1-windows-7-amp-windows-xp-355-82-game-ready-display-driver-feedback-thread/

Hotrod

As always Jeremy will have the best insight but the more you can find yourself, the faster the solution comes. Thank you very much for providing feedback here where it does the most good. If you suddenly get it just right please don't forget to let us know what fixed your problems. I know very little about the technical but I learn the most right here. :)

lmstearn

Turned off the VS GPU acceleration feature which helps a bit. Hmm, given time the bottleneck might reveal itself. Possibly bus related?
I often have more than one VS editor window. This is an issue with large projects, and obviously beyond the scope of Process lasso.
The current Sys Power Status is:

1.40 Ghz 6 out of 6 cores of 3.81hz
Parking AC:10% Parking DC: 100% Freq Scaling AC:5% Freq Scaling DC: 5%


It's always tricky walking the fine line holding conservation of energy in one hand and functionality of applications in the other. :P

edkiefer

That power profile is a energy saving one , if you use Idle saver then setup VS to use bitsum HP power profile when it runs (option>config app power profile ), that might help a bit .
Bitsum QA Engineer

Hotrod

Would setting VS as a game do the same? If so remember that a process set as a game cannot also have a CPU priority set. Gaming mode would automatically raise priority as needed as well as automatically kick into the HP plan. The other priorities I think can be applied though(memory and i/o) please correct me if I am wrong.

edkiefer

Yes, it would basically , it would auto set power profile and set idle saver off by default .
The only thing I am not sure if there are any child exe run under VS ,if so not sure how those be handled .

It's worth a try an see how it does .
Bitsum QA Engineer

Jeremy Collake

Sorry I didn't get to chime in here sooner since I am the one who is also a developer and actually uses Visual Studio daily ;).

During builds is when ProBalance shines. You can do a multi-threaded build of a large project and it will handle all those msbuild.exe, link.exe, etc.. instances that might inhibit responsiveness. The difference is night and day, really. With ProBalance, the PC performs alright (though devenv.exe may be laggy as always, see next sentence).

The GUI of Visual Studio itself is just naturally laggy due to the IntelliSense, which is both amazing and frustrating at the same time ;p. I can't do much about that.
Software Engineer. Bitsum LLC.