Suspend checkmark not working.

Started by ndjamena, November 02, 2016, 06:52:50 AM

Previous topic - Next topic


Windows 10 x64

I was running ffmpeg in the background while playing sc2 and started getting laggy so I tried suspending the ffmpeg process.  After I'd exited the game I right-clicked ffmpeg but couldn't find any way to resume.  So as not to lose the process I started MPC-HC and suspended that process to experiment with but couldn't find any way of resuming that either.

I googled and learned of Process Explorer, downloaded it, shut down process lasso and tried resuming ffmpeg with Process Explorer but ffmpeg just kept suspending.

I opened up Process Lasso again, looked at ffmpeg and a checkmark had appeared on the suspend process option.  I pressed the checkmark and resumed THEM, however, there was still no checkmark in MPC-HC and ultimately I was forced to terminate the MPC-HC process just to get rid of it.

I've tried suspending MPC-HC again and the same thing has happened.  I'm not willing to experiment with ffmpeg until the processing is complete.


Hi, I don't think PL or PE can do anything with suspended processes done by windows, that has to be done by using the application.

On, the advanced suspend process, I think that's more for user enabled, not if Win10 does it and it is still an advanced experiment option ATT.

I tried unsuspending some background processes and could not do it in either PE or PL .
Bitsum QA Engineer

Jeremy Collake

Ed, he manually suspended this process, not Windows.

There is a known bug with this feature that popped up when I made a fix to an interoperability issue with one of MalwareBytes BETA projects.

I did not realize anyone was using this buried feature, so will check into it immediately.

FWIW: I never recommend suspending processes. Instead, limit them to a single CPU core (CPU affinity).

Software Engineer. Bitsum LLC.


I had to check there was this option (it must be new) but It worked for me when I did it on a process, it didn't work when win10 did the suspending, like mail app.
I never used this setting.
Bitsum QA Engineer

Jeremy Collake

That is also true, it doesn't work with Windows suspends. It is actually very old/ancient feature, just buried deep.

However, there is a bug with regards to it that I am aware of, as I described above, which is most likely the culprit since he used a 'full' Task Manager to unsuspend it.

Software Engineer. Bitsum LLC.