PL not recognized?

Started by bertie97, January 30, 2017, 10:56:55 AM

Previous topic - Next topic


Just trying PC 12.20 with PL beta  & whenever the power management profile changes, PC states '...changed by UNKNOWN from ERROR to ERROR' 
Has there been a falling out between the siblings?!   :P


which is changing power plan, do you have boost enabled in PC ?

Anyway, I don't see any issue here with PC and PL, I get notifacations from whatever one changes it.

That said ver9 is moving fast so I would expect some issues till it matures.

Edit: see if 123beta  helps, just noticed your on .121beta
Bitsum QA Engineer


Hey Ed
PL is doing the changing.

I cannot get a .123b yet.  I get a msg saying I have latest build.


Ok, I am not sure that matters, but I guess wait till it show.
Dev work is going pretty fast on ver9 so new builds should show up soon AFAIK (I got a few updates in last few days).

Edit: I don't know if all I see gets to go public, I know some are, just make sure you got beta option checked.
Bitsum QA Engineer


PL has just jumped up to 129b.
PC still says "unknown ... error... " as before.  I imagine this is just a hook for text output rather than an 'actual issue'.   :D


Not sure what problem is there still, seems fine here, maybe try reinstalling either one to see if it works(I would try PC first).

I assume your on win10 AU builds (1607), not that it should matter.
Bitsum QA Engineer


No I'm on w7x64 mostly. W10 is a PITA.
I had PL update to .131b twice today  (!?)  I have it set to 'notify' for updates. The issue continues. 
PC  certainly likes telling me that msg & seems to do it at times inconsistent with the PL idle-saver schedule....?  :-\

As for w10, I seem to one of many who had major BS with the upgrade to xx.1607.  I purposely waited until the later 'fixed' version was released hoping the early victims had sorted it out.  How wrong can you be?!  :P
I had days of seeing 'restart to finish installing updates' on boot, after multiple failed 1607 patch attempts.  Re-D/L GBs then fail & start again after reboot.
The problem is/was that this failure nukes the patch record.  Win will then not allow ANY further patch to install - great for 'security'.
You either get it to upgrade somehow or kiss goodbye to any future fixes.  I tried all sorts of big cumulative patches & workarounds.  Got nowhere.
C:\Windows\system32>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 61% complete.

Windows Resource Protection could not perform the requested operation.

C:\Windows\system32>Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:I:\sources\install.wim:1 /limitaccess

Deployment Image Servicing and Management tool
Version: 10.0.10586.0

Image Version: 10.0.10586.0


Error: 1392

The file or directory is corrupted and unreadable.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

Several  different error codes.  Normally it failed at exactly 61% regardless of error.

In the end I gave up (like many others if forums are to be believed), & tried a fresh install from rom.
Failed. Failed. Failed.
- W10 tried to take over & do some sort of recovery -reboot & start over.
- I fdisked within w10 setup - a 'clean install' added 400mb to the 'system reserved' partition & yup - FAILED+reboot & start over.

After 3 variations of those 2 patterns I wiped the SSD outside of win control & started fresh.  Went on!
Yaaay only 3 days & total drive contents loss!   :-*

Then I reconnected my other HDD & it decided to re-index the contents.
On cold boot the next day - guess what?  Win says 'oh corrupted HDD - I'm going to 'repair' those TBs...' 5 hours later it finished.  Obviously nothing ran properly after that.
2 days worth of chkdsk on boot & after boot have finally restored the pathways to the effect that I no longer get random bad references being flagged.  It all ran perfectly before that patch, tho perfect isn't a word I normally associate with Windoze.  :P

So yeah w7 is still my go-to.  I learnt with Vista to never trust an MS OS before you get at least one service pack!   ;D


"As for w10, I seem to one of many who had major BS with the upgrade to xx.1607."

I am happy that I haven't been forced to upgrade, yet, on my Surface Book.  :)


If your using PC and PL, with keep alive mode on, are you using boost option in PC?

They both do similar things so use just one.

On WU, I have run into problems with it, but have been able to fix by clearing the folder "C:\Windows\SoftwareDistribution" but first stop WU service.
Then enable it and it should DL and install ok.

Easier way than that is use in control panel >trouble shooter>WU, it does the same, stopping the service, clearing the folder and re-enable the service.

Win10 has been very good so far for me, (knock on wood).
Bitsum QA Engineer


No boost, no keep awake.  PC is the free version, I'm just looking at how they work together right now.

As to w10 - what you refer to was in the early stages along with running thru all the individual update diagnostics + certain key patches (the ones that allow progress to the next group eg .511 to .583 etc). 
--You need d/l & install > not compatible with this OS, d/l  > etc etc etc

I got no answers/fixes & always hit an unknown error at some point forcing me back.  Only by using this script tool was I able to progress at all as the whole catalog had been corrupted by the original 1607 install attempt but I couldn't actually restore it.

Catch 22 - you cannot install a newer patch becos you need the older one; run the older one & it says I'm already installed > loop & repeat for all entries.

I hear this problem has been prevalent enough that MS have pushed a new updater reset tool allowing a roll-back/restore to get things moving again.  Typically the version I needed was only available for post 1607 builds... >:(

Glad you are one of the lucky 27 people the patching system worked for Ed!!  ;D


Ok, well hopefully MS will correct all updating system, or find issue that users can fix.

In my above post I meant idle-saver not keep alive but since you use free PC that doesn't affect you.
Will keep my eye on it, if it comes up here.
Bitsum QA Engineer


Thanks Ed

Didn't really mean to hijack my own thread, but w10 is a sore point at the moment... You guessed right?  ;D


On b157 I still see this msg, I began to wonder if PC is redundant with PL running, is it?


I am still not seeing this, but does it happen with only one application running, just PC ?

Edit: I think this must be a win7,XP problem as I tested a few install modes and can't get it to fail but they are all Win 10 OS's.
Bitsum QA Engineer


I'm using w7x64.
This occurs every time PL does its' idlesaver routine.
Doesn't matter if anything or nothing is running ...It directly responds in this way to PL & PL is always running  ;D


Updated PC to today - 'problem' still persists.  :-\

Jeremy Collake

This is something I am tracking and have had reported. Please hold for an analysis. I am taking one day at a time with a task load this large!
Software Engineer. Bitsum LLC.

Jeremy Collake

... and please switch to the new forum, I have a hard enough time monitoring one. I will hopefully have an answer for this soon, we are about there.

Any time any critical issue arises, always go through the Support channel, as that is the only way you get guaranteed, well, support ;).
Software Engineer. Bitsum LLC.


Thanks for looking at this.  It's not destroying my life so I figured I'd just note it here, BUT if PL had broken that would a whole other thing!  :P  ;)
......didn't realize there was a new forum   ::)


This is another FYI
I re-regged  for the new forum, & got 2 activation links - these didn't work in Opera but did in IE. 

See attached screen.

Maybe I should have migrated instead... ???

Jeremy Collake

Thanks bertie, we had a service provider crap out on us, that was the cause of the error.

This seems to be a known issue with Windows 7 at present. I am addressing it ASAP.
Software Engineer. Bitsum LLC.


Thanks JC 
I know you have to prioritize the 'real' issues, so whenever you are ready is fine  ;)

.....Decided I better buy it as I'm making you jump thru hoops  ;D

Jeremy Collake

The issue here is Windows 7 compatibility (or at least some editions of it). In any event, what I am temporarily doing is changing the message to something more generic - like telling you it changed, but not mentioning to and from and by who. Not ideal, but a good and safe work-around while I look into it deeper.

This is in ParkControl v1.1.5.0 and later.

Software Engineer. Bitsum LLC.


That is a nicer msg thanks JC ! ;D

I'm running W7x64 Ult. +
PL &  PC

Jeremy Collake

Yes, this is a known issue, that is why the message is 'friendly' in telling you it doesn't know much. I may just remove it if it has no data, unclear. Still sorting through this, may be able to fix. It is a Win7 issue.
Software Engineer. Bitsum LLC.

Jeremy Collake

Check Device Manager while it is plugged in to confirm what device has a missing driver or is malfunctioning.

It is not clear to me how this relates to PL (Process Lasso).
Software Engineer. Bitsum LLC.

Jeremy Collake

Disable power plan change notifications (a checkbox on the main ParkControl window) and it will clear up. The cause is most likely some issue with the Windows Event Log service, though I don't have more specific guidance at this time.
Software Engineer. Bitsum LLC.