PL & Windows 10 1703 Power management

Started by bertie97, December 02, 2017, 07:01:46 AM

Previous topic - Next topic


I think I have found an issue with & Win10 1703 b15063.726.  I am blaming MS not PL, but maybe PL can save the day?
Specs -
W10 Pro x64, 1703 b15063.726
Ryzen 1800x, B350, 16gb 3200 DDR4.

PL x64

I was suspicious of letting the OS have 1703 & turns out I shouldn't have done it.  Not only do I now have an extra <30gb of windows.old eating up the SSD but PL & power management control generally are shot/hidden regardless of Admin privileges.

I normally have HiPerf  & switch to PSave when inactive for xx secs in PL idlesaver.
Now post 1703, PL can sometimes incorrectly switch to PS mode whilst I am doing 'light' work - CPU use below 5%, just typing or moving mouse etc. 
See screen - PL shows high CPU use & low CPU use, mobo temp etc monitor shows CPU use has dropped - this was taken after Handbrake was run for <50mins & then had stopped for 5+ mins.  PL TaskBar icon was fully green too.

W10 will not obey any 'Prevent Sleep' command set by PL.  I have set it on several progs  eg - VLC, imgburn & handbrake & w10 will still go to sleep with the progs running. 
With VLC & Handbrake, W10 at least lets them finish working before suspending, with imgburn it will lock up the prog (req's reboot to recover the prog) when it enters the verify stage of a burn.

I have also been scouring the event logs to see why sometimes now I must do a hard reset to recover the system, in the middle of several progs running. 
Only thing I can see is the PL power management switches are close chronologically.  I suspect that w10 sees the shift to Power Saver as a reason to put the PC into suspend mode regardless of what I'm doing, unless there is high (70%+) CPU use.
It appears to lock mid way into suspend, as the progs suddenly start to become inactive/unselectable by mouse or <TAB> etc.  One by one they stop responding until the PC locks up completely.


Non-PL-related Rant :P ->

I am extremely p#### off with the uncontrollable suspend/hibernate functions + forced login screen.
I haven't found anything that will fully remove the login demand for a session that has been suspended by w10 itself.  Cannot even fully turn off hibernate any more AFAIK.

I have successfully turned logon off for cold boot (& stopped hibernate-based fast boot) & for when I specifically tell it to sleep but this BS will not stop ruining my user experience.
Maybe Sysinternals Autologon could work for the OS-called suspend?

Having just upgraded to a new rig that of course wants w10 for all the hardware features, what was a smooth & impressive system is now a PITA thanks to v1703. 
I shouldn't need to spend days searching thru forum posts that have been made obsolete by this update for this simple setting... I can't help thinking that Win as a service means paying for an endless beta test licence.  At least the old system had a point where OS maturity meant it would not suddenly screw something vital on every-day tasks as you could turn off/select updates & isolate the machine easily.



Hi Bertie97

Have not seen this yet on 1703 but I am on Intel i5-3570k right now.

One thing, with PC and PL. I would suggest setting up PC power settings (park cores, etc) but don't run both PL and PC at startup (Just run PL).
This is because of overlapping features, not saying this is your problem at all but may simplify things.

With regard to issues with handbrake, is it showing suspended when running in status in PL GUI or task-manager?
Have you tried raising Vcore voltage a tad to see if it might stabilize it, stop the unresponsiveness ?

OT: I have 1709 on a 3 month delay here on main system cause of many issues but 1703 works here, I am going to run some tests to see if i can replicate any of your issues.

Edit Anti sleep is working here (PL, set prime95 (don't have handbrake) to display and sleep and it works. I have this main system with hibernation disabled so it can't sleep but display can normally. I used powercfg -h off, along with fast boot disabled.

In your screenshot looks like Asus suite , are you also running and AMD power/CPU app, wattman etc. Maybe try use only one if so.
Bitsum QA Engineer


Hey Ed, thanks for the reply.
I'll disable PC & see what happens.

As you can see on that screen PL shows both states - low & high, HB was at full stop, & TM showed it as no CPU use.
When it's running it does show correctly metered by PL.

Yep Asus, nothing of theirs that forces things is running AFAIK, I've been manually adjusting fan speeds via that GUI to test my new liquid cooler.
Other than that it's all BIOS settings.  This mobo auto clocks volts when the tuning phase is run & as it hasn't affected stability under load I hadn't thought I should mess with it.  Ryzen volt setup isn't the same as earlier gens from what I've read.
It seems rock solid & very fast under real load.  Did a drive image (256gb ssd) in under 8 mins in WinPE, & 9mins within the OS.  Both images on high comp. & were error free.

I will see whether I can get some sense via cmd. 
I have tried disabling away mode & hybrid sleep but cannot yet tell if it's actually 'worked'.

My issues seem to be about stopping/stopped procs -> suspend.  It was (surprisingly) great with 1607 by contrast.    I attach the report via powercfg, the last group (yellow) were invoked by me: <win> & select sleep.  the abnormal ones were OS invoked.

OT how come the site says build 413, PL says 402 & running check for updates says latest version already installed?  Just a typo?


Ok, I am forwarding this thread to Jeremy, as he uses AMD stuff.

Only thing i can think of off hand is make sure your on latest bios, I know Ryzen is getting lots of updates on bios.

On PL version, if you have beta ticked off you should get .413b, otherwise .402 is release version.
Bitsum QA Engineer


OK thanks Ed.

BIOS is latest - 2017/11/20 - definitely helped to upgrade that from the mobo supplied state! 
It was doing some weird things, but they did reveal just how far they've come on BIOS & reboot vs lockup/recovery - pretty impressive seeing it auto restart a bunch of times until it found a volt/clock setup that allowed it to start OK with the new ram & cpu.  Wasn't so long ago I would have had to sit & try out all those settings manually.   ;)

I missed the checkmark on betas, so used to that being ticked I didn't even look... !!!   ::) :-[  Am updating to beta 413 now.

Now it's a hurry up & wait game to see if the PM changes stick. 

Bit OT -  Hate that they removed the req PW on wake option in PM.  Why shouldn't I have the option?!  Surely the security thing should be down to me & if only I use the PC, I should be choosing how it's locked when I'm AFK.