High Memory Usage

Started by tango57, April 16, 2011, 12:40:04 AM

Previous topic - Next topic


Hello, I recently tried the v4.00.34 64-bit of Process Lasso and I really like it so far and it had been running fine on my system (i.e. no crashing or freezing of any of my programs) except for one thing.  After using it in ProBalance automatic mode and with all the default settings for several hours I noticed nearly all of my system RAM would get consumed but I'm not quite sure where it's all going  ???.  It appears that in general all my programs running are each using up a little more RAM than usual because I don't really see one particular program hogging all of the RAM except for Firefox which hogs bout 500 to 600 MB but I always run Firefox with like 10 or more tabs open.  This never happened before on my system.  Normally with all my programs I run, my total RAM usage consistently hovers around 2.8 GB used but after running Process Lasso for several hours my RAM slowly gets used up and will reach over 7 GB used at which point I will have to reboot my system  :o.  After uninstalling Process Lasso my RAM consumption goes back to around 2.8 GB and stays that way.  I installed, ran Process Lasso for a few hours then uninstalled it and did this twice and each time it ran on my system, I confirmed my total RAM usage did go up past the 7 GB mark.  I'm just curious as to how Process Lasso is affecting my RAM usage either directly or indirectly or if maybe an interaction with another software on my computer might be causing this effect.  If anyone can offer any insight or solutions as to why this is happening I'd appreciate it much cause it seems like only my computer is being affected in this way since I couldn't find any other topics about this  :(.  Btw, my main system specs are Windows 7 Home Premium 64 bit service pack 1, Phenom II X6 190T 3.2 Ghz, 8 GB DDR3 RAM, ATI HD 5700 x2, and WD 500 GB HDD.  Thanks in advance for any help or advice!  :)

Jeremy Collake

I responded a bit hastily, I apologize.

Since you did uninstall Process Lasso and the problem appeared mitigated, do check to see how much memory Process Lasso is using. As I said, it can't affect how much virtual memory other processes are using, but it can consume virtual memory itself. Of course, I check for memory leaks and other bugs, but it is not impossible that some scenario slipped by testing. However, *IF* that is the case, you will see the virtual memory consumed by Process Lasso -- not 'hidden' anywhere. If Process Lasso isn't consuming the virtual memory, then it isn't consuming it ;o.

I would recommend using Process Explorer to check for virtual memory consumption. Perhaps it can help tell you where it is going. Sometimes in task managers you are just looking at the amount of virtual memory actively in use, and not the total amount consumed. If you discover it is going to Process Lasso (like I said, which would be clearly indicated), then do let me know.

Regardless of the cause, I am sorry to hear of this problem and I hope you are able to identify the cause (mostly because I'd hate to leave you thinking Process Lasso was responsible).
Software Engineer. Bitsum LLC.

Jeremy Collake

As a side note, my hardware and OS is almost identical to yours. I'd really be on the lookout for possible malware problems, maybe a rootkit or something. That would explain virtual memory consumed, but seeming to be 'nowhere'.

I kind of jumped in my first response (now deleted), as a report of a memory leak is very serious and I've had no such reports from any other user, or seen such in my own testing. Further, to consume that much memory would require a massive leak ;o.

So, I *REALLY* don't think Process Lasso is directly responsible here. Could it be indirectly responsible? It's hard to imagine how... Like I said, use Process Explorer to find out where that virtual memory is going. Then you'll have a better idea of what the heck is going on.
Software Engineer. Bitsum LLC.

Jeremy Collake

Lastly, I forgot to mention that *IF* by chance you use Norton Internet Security 2011, you may want to upgrade to the beta. Its new DeepGuard has some issues with Process Lasso. I can't say that is the cause of the trouble, but just throwing that out there. Honestly, disappearing VM can be a sign of malware, but so can EVERY OTHER PC malfunction, lol ;)
Software Engineer. Bitsum LLC.