Author Topic: BitDefender (Antivirus) Not Hard-Coded; Hangs w/Constant CPU Affinity Reset  (Read 701 times)

Offline nah1982

  • New
  • *
  • Posts: 3
I noted that BitDefender (the antivirus) and it's sub-processes don't appear to be hard coded to be excluded. I set them to be ignored, or tried to set CPU affinity broad so they would be ignored. It just constantly trys to set their affinity and errors out every couples minutes. If I set "More strictly enforce default affinities" it literally constantly is trying for it, and freezing up the system; I have to disable for it to default to every couple minutes. If there is a way to force it to ignore them in all instances, your feedback is appreciated.

Otherwise, to fix them and hard-code to be ignored, the list of processes are:

bdredline.exe
bdagent.exe
bdservicehost.exe
bdtrackersnmh.exe
BdVpnApp.exe
BdVpnService.exe
bdwtxag.exe
bdwtxcr.exe
DevMgmtService.exe
updatesrv.exe
DiscoverySrv.exe
ProductAgentService.exe

Sincerely,
nah1982



Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5351
  • Gender: Male
  • The Lasso
    • Bitsum
You definitely don't want to try to set their CPU affinities or other attributes. Security suites protect their processes from tampering so that malware can't mess with them.

Do you have some all-inclusive wildcard set, and that is the problem? If so, you'll need to whittle that down to more selective rules.

Software Engineer. Bitsum LLC.

Offline nah1982

  • New
  • *
  • Posts: 3
As you'll note from the screenshot, the only rule set is a default restriction of 0-15; I didn't put that, and if I click to set "No Default Affinity" it keeps that. The X rule set is to have ProBalance ignore it. Otherwise, no other rules are applied. It still results in SYSTEM trying to set the affinity and it faulting out, as noted at the bottom of the screenshot. You can also see by the attached ini that they are cleared as well.

Any assistance or guidance is appreciated. Thank you.

Sincerely,
Nathaniel Hatten

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5351
  • Gender: Male
  • The Lasso
    • Bitsum
Open 'Options / CPU / Configure persistent CPU affinities' and uncheck 'Match command lines' at the bottom. That seems to be the source of your troubles. I am evaluating it now. This issue appeared in the last final version, 9.7.5.

That option may be removed now that regular expression matching covers it.

Update: This will be fixed as of 9.7.6.9 beta.

Thank you for reporting this!

« Last Edit: April 26, 2020, 03:50:13 PM by Jeremy Collake »
Software Engineer. Bitsum LLC.

Offline nah1982

  • New
  • *
  • Posts: 3
Thank you for the advice. Turned that off and it solved it. Much appreciated!

Sincerely,
Nathaniel Hatten