Author Topic: Turning logging off doesn't work  (Read 836 times)

Offline Keefaetana

  • New
  • *
  • Posts: 6
Turning logging off doesn't work
« on: January 21, 2021, 12:33:59 PM »
I've turned logging off in Process Lasso by un-checking "Logging enabled", but Lasso still keeps on adding actions to the log. I am currently using the version 9.9.4.79 beta. I haven't noticed the issue before, but it may have already existed in previous versions.

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1789
  • Gender: Male
Re: Turning logging off doesn't work
« Reply #1 on: January 21, 2021, 06:04:35 PM »
Thanks for the report, it seems to be working fine on my end (9.9.4.81 beta) but will test some other options.

PL is undergoing some big changes in logging, but we are currently testing now.
« Last Edit: January 21, 2021, 07:28:37 PM by edkiefer »
Bitsum QA Engineer

Offline Keefaetana

  • New
  • *
  • Posts: 6
Re: Turning logging off doesn't work
« Reply #2 on: January 22, 2021, 02:13:52 AM »
Thank you for replying.

I additionally tried un-checking all the individual "Log process launches", "Log process terminations", and everything below it. The issue still persists.

Next up, I exported my settings and reset my configuration via Options. Let's see if that fixes the issue.

EDIT: Nope, doesn't fix the issue fully. The only settings I changed after resetting the whole configuration was to disable logging by un-checking "Logging enabled", and to enable "Lower I/O priority during restraint", and very soon "I/O priority class lowered" shows up in the Actions log. Also, I updated to 9.9.4.81 beta before the latest test.
« Last Edit: January 22, 2021, 02:45:27 AM by Keefaetana »

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1789
  • Gender: Male
Re: Turning logging off doesn't work
« Reply #3 on: January 22, 2021, 07:47:03 AM »
Can you try something, note any change then open the config file in (prolasso.ini) by Menu, File> "manual edit the config file".
See if your changes match what the file says under [Logging] halfway down the file.


Edit, Thank you for the detailed report, no need to test my above comment, I have repro your test. It is the option "Lower I/O priority during restraint" that is causing it.
« Last Edit: January 22, 2021, 07:51:26 AM by edkiefer »
Bitsum QA Engineer

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5411
  • Gender: Male
  • The Lasso
    • Bitsum
Re: Turning logging off doesn't work
« Reply #4 on: January 22, 2021, 11:01:47 AM »
This will be fixed in 9.9.4.83. It did exist in all prior versions. The option to lower I/O priority during ProBalance restraints is seldom used, so this was missed until now. Thanks for reporting it!
« Last Edit: January 22, 2021, 11:04:09 AM by Jeremy Collake »
Software Engineer. Bitsum LLC.