NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit to request account activation.

Main Menu

Turning logging off doesn't work

Started by Keefaetana, January 21, 2021, 12:33:59 PM

Previous topic - Next topic


I've turned logging off in Process Lasso by un-checking "Logging enabled", but Lasso still keeps on adding actions to the log. I am currently using the version beta. I haven't noticed the issue before, but it may have already existed in previous versions.


Thanks for the report, it seems to be working fine on my end ( beta) but will test some other options.

PL is undergoing some big changes in logging, but we are currently testing now.
Bitsum QA Engineer


Thank you for replying.

I additionally tried un-checking all the individual "Log process launches", "Log process terminations", and everything below it. The issue still persists.

Next up, I exported my settings and reset my configuration via Options. Let's see if that fixes the issue.

EDIT: Nope, doesn't fix the issue fully. The only settings I changed after resetting the whole configuration was to disable logging by un-checking "Logging enabled", and to enable "Lower I/O priority during restraint", and very soon "I/O priority class lowered" shows up in the Actions log. Also, I updated to beta before the latest test.


Can you try something, note any change then open the config file in (prolasso.ini) by Menu, File> "manual edit the config file".
See if your changes match what the file says under [Logging] halfway down the file.

Edit, Thank you for the detailed report, no need to test my above comment, I have repro your test. It is the option "Lower I/O priority during restraint" that is causing it.
Bitsum QA Engineer

Jeremy Collake

This will be fixed in It did exist in all prior versions. The option to lower I/O priority during ProBalance restraints is seldom used, so this was missed until now. Thanks for reporting it!
Software Engineer. Bitsum LLC.