News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

Watchdog not terminating processes

Started by tsorzano, June 28, 2012, 09:26:52 AM

Previous topic - Next topic

tsorzano

I downloaded the demo process lasso server v5.1.0.98.  Running on windows 2003 terminal server.  I installed to see all user processess but only run manager and agent in my admin account.   I disabled probalance features.

I want a watchdog to terminate any processes that takes 95% of cpu for more then 15 seconds.

I used * for the process name.  Is that a valid entry to specify any process?

To test I browsed to hxxp://www.fossiltoys.com/cpuload.html  and selected 100%.

Watching the lasso manager I can see iexplore.exe taking 100% of the cpu.  However the watchdog never terminates the process.

Any suggestions

Thanks,

Troy

Jeremy Collake

I am not sure what the malfunction may be, but you may want to try a Restart instead of Terminate, see if it changes the behavior. You may have stepped into a safety catch...

I STRONGLY RECOMMEND you not use '*' though and instead target specific process(es). You can use wildcards, just not one that includes all processes on a 'Terminate' rule.. For your own safety. Also note this operation is very unsafe. The entire rule is unsafe, but the termination itself is also quite unsafe (inherently as a forced termination).

You might have better luck with ProBalance, if your intent is what I believe it to be. Check the extended options in the ProBalance configuration dialog.

Version 6 further expands the watchdog rules a lot, BUT it is still in early alpha so would need to be used with great care.
Software Engineer. Bitsum LLC.