News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

Automatic Updates [FIXED v6.0.2.44, future auto updates to work]

Started by Tarnak, January 13, 2013, 07:02:02 PM

Previous topic - Next topic

Tarnak

I can only update the program manually. This has just started to happen with PL, recently.

P.S. I just noticed that from v6.0.2.41 beta, that a fix has been made for automated update in XP.

edit: added PostScript

Jeremy Collake

The XP auto update issue is now fixed (and verified this time) internally. The localization of the download progress dialog has also been improved. However, I have run into a couple blockers and will have to issue a beta first to further review all these changes. There are several other misc fixes and enhancements.

The prior beta .41 does not fix this, as it purports incorrectly in the change log.
Software Engineer. Bitsum LLC.

Tarnak

 Thanks....I notice that in v6.0.2.43 beta, that the automatic update is still not working in XP.

How from the  changes history of this beta, I note that "Fixes automated update in XP (will be seen working again in next update)"

parkd1

It worked for me so it must just be an XP issue.

danlock

Yeah, it's (apparently) an XP issue.  It's been present for the past few updates. Now that I've installed the .43 beta, I hope the future automatic updates will function as expected again  ;)

BenYeeHua

Ya, so it will be tested on the next beta update. ;)

Jeremy Collake

Yes, I incorrectly reported it fixed in .41, but later fixed and tested it in .43. The next update will work correctly, *if* upgrading from .43.

The final will come shortly, I'm about done with code review and additional testing.
Software Engineer. Bitsum LLC.

Tarnak

 Just got the update for the new .44 version, but it still not auto updating.

Tarnak

  Went with a manual update, just now...and it is OK.   I will see how the next version goes for the auto update. ;)

Jeremy Collake

Well, now is your chance to try ;). Assuming you updated to .43. Or you could download .43, then update.
Software Engineer. Bitsum LLC.

Darth Continent

I just experienced this in the version I had prior to .44, to which I've updated manually; I'll holler if I encounter this issue again in trying to auto update to the next version.

Jeremy Collake

BTW, I have later confirmed that this issue would also affect Vista+ systems where the user had a space in their user name. Yes, the issue was a space in a pathname (classic ;p). In XP, the default path for appdata contains a space, hence its constant failure. In Vista+, the path does not contain a space unless the user name does.
Software Engineer. Bitsum LLC.

Tarnak

Just tried another snapshot, manually updating from .38 to .43. and this time the auto update worked for me in XP.  :)

All is Tickety-boo.  ;)

danlock

The most recent update (*.44 as of ~5:30pm MST 2013/01/16 [ 2013-01-17 00:30 GMT ]) automatically downloaded and installed for me upon booting. No errors observed.  ;)

I'm not familiar with the phrase "Tickety-boo," but a quick search seems to imply that it means "in working order", so all is Tickety-boo for me too!  ;D

Jesse

Simon

Hi All

Last few updates have not updated automatic for me including .44 today. I run Win7 64.   No problems with manual update.  Any ideas?
Kind Regards

BenYeeHua

Quote from: Sizel on January 18, 2013, 06:27:35 AM
Hi All

Last few updates have not updated automatic for me including .44 today. I run Win7 64.   No problems with manual update.  Any ideas?
Download the beta build, install it to testing again?
And this bug is for XP.

Jeremy Collake

The fix won't be visible until you next update (from .44 to whatever comes next). If you want to see it work, install 6.0.2.43 beta and then update it ;). Otherwise, you have to wait until .46 or whatever the next build is to see it work properly once again.

In the interim, there is the /S switch for the installer, which will do a silent/unattended installation. Other command line options are documented here: http://bitsum.com/docs/pl/Command%20Line%20Arguments/command_line_arguments.htm (http://bitsum.com/docs/pl/Command%20Line%20Arguments/command_line_arguments.htm)
Software Engineer. Bitsum LLC.

Simon

Quote from: Jeremy Collake on January 18, 2013, 10:33:33 AM
The fix won't be visible until you next update (from .44 to whatever comes next). If you want to see it work, install 6.0.2.43 beta and then update it ;). Otherwise, you have to wait until .46 or whatever the next build is to see it work properly once again.

In the interim, there is the /S switch for the installer, which will do a silent/unattended installation. Other command line options are documented here: http://bitsum.com/docs/pl/Command%20Line%20Arguments/command_line_arguments.htm (http://bitsum.com/docs/pl/Command%20Line%20Arguments/command_line_arguments.htm)

Ah, ok. Thanks for the clarification :)
Kind Regards