News:

NOTICE: This forum is mostly an archive, though new posts are allowed. Registration may require manual admin activation. After registering visit https://bitsum.com/contact/ to request account activation.

Main Menu

Tray Icon

Started by parkd1, April 17, 2014, 04:29:06 PM

Previous topic - Next topic

parkd1

Sometimes at windows boot up the tray icon is getting stuck a the stop light icon.

BenYeeHua

And did it showing "the core engine is not running" when you move your mouse over it? :)

parkd1

It seem to work alright.

BenYeeHua

I wonder can it be the UI boot earlier than the Engine, then it stuck on that icon, even the Engine is enabled...
---
So, how often did this happen?

parkd1

Only seen it like three times. What should I look for the next it happens? At work now so will check on it tomorrow.

BenYeeHua

Not too sure...

Maybe the Process Lasso log that record when it boot?

edkiefer

App like this with multiple modules it might be good idea to have PL governor be main process and then have the gui delayed start of a sec or two .
Bitsum QA Engineer

BenYeeHua

But, the UI did delayed at boot...

If you check your shortcut, it is "C:\Program Files\Process Lasso\ProcessLassoLauncher.exe" /nodelay, so it is delay at boot. :)
And there are many times I has a long boot time, I don't facing this issues yet...

edkiefer

Ok , didn't know it was already there .
I don't run it at startup so never really looked, checked .
Bitsum QA Engineer

BenYeeHua

It can be also the delay is for UI+Engine, I can be wrong. ;D

Anyways, I think only Jeremy know what's happen. :)

edkiefer

what timestamp is on each process will tell you if GUI is delayed or both same time ?
(Creation time in PL data ) for starting from shortcut there is only a sec difference between governor and GUI
Bitsum QA Engineer

BenYeeHua

Not sure, I don't do any much research yet.

And for boot, it is 2 task, 1 for UI, 1 for Engine.
----
Anyways, I really has no clue for why OP is having this issues...

parkd1

The system tray icon is struck at the stop light again. When I click on it to open it, it seems to open just fine Is there a file I can send so that you can see what is going on. Do need to start something so that it will log it?

BenYeeHua


parkd1

Ok I see how to get the debug but when I try to do it it is grayed out so I can not click on it.

BenYeeHua

Not sure what's you means(like which button or UI is grayed out), but you can try Process Explorer with Admin right.

PS:Just make sure, only create the dump when PL is having this issues, but you can try to dump it when it is normal, to check that the dump function is working. :)

parkd1

I do not have Process Explorer but tried to do it with Task Manager and it was grayed out. I can get Process Explore and try it.

BenYeeHua

Hmm, I hope this is not caused by not having WinDBG, as Windows has a Windows Error Report that create and collect dump too.
Just tell me if Process Explorer can't dump the process, it can be UAC too. :)
PS:Remember to set Process Explorer as Admin right. ;)
PS2:It is portable software, so don't worry about installing it. :D

parkd1

Ok Sounds good. Will give it a try and report back.

parkd1

Ok that will work. Now what should I do? The mini ot the full?

BenYeeHua

I would choose Full dump, so it make sure all information is dump, and I think it should not having too large file size, after compressed by using ZIP or RAR. :)

parkd1

Ok sounds good. Looks like I will have to email it.

BenYeeHua

Yup, if the file is too large and you has a slow upload speed, I will said upload to some file sharing website.
And if you don't trust the file sharing website, then password protect is a good choose too. ;)

parkd1

I have e-mailed it so now we just have to wait now.

Jeremy Collake

I just returned from vacation.

The cause of this is most likely one of these:

1. The GUI is starting before the governor. In this case, the tray icon should eventually change (give it up 2 mins)
2. The governor is sometimes crashing shortly after it starts. In this case, the tray icon would remain red until the governor starts.
3. The governor is not starting. In this case, you'd see this behavior on every boot.

If a crash does occur, then the minidump will be useful to me. Otherwise, it won't be.
Software Engineer. Bitsum LLC.

BenYeeHua

Quote from: support on May 13, 2014, 11:41:48 AM
I just returned from vacation.

The cause of this is most likely one of these:

1. The GUI is starting before the governor. In this case, the tray icon should eventually change (give it up 2 mins)
2. The governor is sometimes crashing shortly after it starts. In this case, the tray icon would remain red until the governor starts.
3. The governor is not starting. In this case, you'd see this behavior on every boot.

If a crash does occur, then the minidump will be useful to me. Otherwise, it won't be.
Hi, I think you may want to check this high priority issues first. :)
https://bitsum.com/forum/index.php/topic,3802.0.html
----
So I guess, if no crash, then even a fulldump is useless?

Jeremy Collake

Quote from: BenYeeHua on May 13, 2014, 11:44:25 AM
So I guess, if no crash, then even a fulldump is useless?

Depends on what I'm looking for, but that's generally true. The exception would be cases of memory or handle leaks.
Software Engineer. Bitsum LLC.

BenYeeHua

Quote from: support on May 13, 2014, 12:06:30 PM
Depends on what I'm looking for, but that's generally true. The exception would be cases of memory or handle leaks.
Roger that. ;)

BenYeeHua

Interesting, I just facing this issues now, and bad news.
Quote1. The GUI is starting before the governor. In this case, the tray icon should eventually change (give it up 2 mins)
2. The governor is sometimes crashing shortly after it starts. In this case, the tray icon would remain red until the governor starts.
3. The governor is not starting. In this case, you'd see this behavior on every boot.
All of this is not the answer, I had give it up 2 mins, and it is still showing Process Lasso icon, the log showing governor is running and restrain too.
The start up time is same for both of them, so it also don't crash.

By pointing the PL tray icon, it is showing "Process Lasso", not any information like the Governor is not running or CPU usage etc are showing.

That's all, by fixing this, all I need to be do is just restart Process Lasso UI, not Governor. :)